If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After focusing the icon in the right-top corner in tabcandy, trying to activate tabcandy afterwards goes imediately back to normal view

VERIFIED FIXED in Firefox 4.0b7

Status

Firefox Graveyard
Panorama
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: smaug, Assigned: raymondlee)

Tracking

unspecified
Firefox 4.0b7
x86
Linux
Dependency tree / graph

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

7 years ago
I don't know what the icon is for, but seems like it somehow exists the
tabcandy view. 
But the focus also stays in that icon, so that if I afterwards try to go to 
TabCandy, TabCandy is activated by it exits immediately.

Sounds like the icon was tested only on OSX, where focus handling is 
quite different (and IMO OSX in general has pretty insane focus handling).
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
(Assignee)

Updated

7 years ago
Blocks: 594094
(Assignee)

Comment 1

7 years ago
Created attachment 475031 [details] [diff] [review]
V1

This will require the patch for bug 595191 to land first because this patch uses the blurAll method
Assignee: nobody → raymond
(Assignee)

Updated

7 years ago
Depends on: 595191
(Assignee)

Comment 2

7 years ago
Pushed to try and waiting for the results
(Assignee)

Comment 3

7 years ago
Passed try
Comment on attachment 475031 [details] [diff] [review]
V1

+    if (navigator.platform.indexOf("Mac") != -1) {
+      charCode = 160;
+      eventObject = { altKey: true };
+    } else {
+      charCode = 32;
+      eventObject = { ctrlKey: true };
+    }

Use KeyEvent.DOM_VK_SPACE instead of the 32, and comment the 160 to make it clear that that's the character code for option + space. 

Have you verified this fix on Windows?

I'm a little confused by this... isn't it just space we're looking for? Or is option space a different character code? Also, shouldn't we be using
(In reply to comment #4) 
> I'm a little confused by this... isn't it just space we're looking for? Or is
> option space a different character code? Also, shouldn't we be using

Please ignore these lines; earlier draft... clearly I figured it out. :)
(Assignee)

Comment 6

7 years ago
Created attachment 475120 [details] [diff] [review]
v2

I've tested this patch on Windows 7 and it worked fine.
Attachment #475031 - Attachment is obsolete: true
Attachment #475120 - Flags: review?(dietrich)
(Assignee)

Comment 7

7 years ago
Comment on attachment 475120 [details] [diff] [review]
v2

It requires the patch for bug 595191 to land first because it
depends on the blurAll method
Comment on attachment 475120 [details] [diff] [review]
v2

r=me. before landing, please add some commentary to the test.
Attachment #475120 - Flags: review?(dietrich) → review+
Created attachment 475225 [details] [diff] [review]
patch v3 (ready for check in, needs to land after 595191)

Updated patch with comments, as well as r+ in commit message. Also, the test had the wrong bug number (595191); fixed.
Attachment #475120 - Attachment is obsolete: true
Attachment #475225 - Flags: approval2.0?
Also note that this patch still requires bug 595191 to land first.
You can clear the approval request - marked blocking betaN+
blocking2.0: ? → betaN+
Attachment #475225 - Attachment description: patch v3 (ready for check in, except needs a+ mention in commit message) → patch v3 (ready for check in, needs to land after 595191)
Attachment #475225 - Flags: approval2.0?
(Assignee)

Updated

7 years ago
Blocks: 595763
Created attachment 475552 [details] [diff] [review]
patch for check-in [r=dietrich, a=blocking]

Updated patch with comment message, and remerged with 595191.
Attachment #475225 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Pushed http://hg.mozilla.org/mozilla-central/rev/633ec4ed3cb2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b7
(Assignee)

Updated

7 years ago
Duplicate of this bug: 595763
verified on recent nightly builds of minefield
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.