netlanski movie (netling) returns incorrect value for getNextText, error 4836

VERIFIED FIXED

Status

()

P3
blocker
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: ekrock, Assigned: peterlubczynski-bugs)

Tracking

({shockwave})

Trunk
x86
All
shockwave
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [branch accept], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Hived off from bug 54205, "Netlanski movie (netling) hangs when "getNetText"
button is pushed in Netscape 6 (Mozilla) [@ IML32.dll]," since browser no longer
crashes but the wrong value is returned and an error occurs.

Kelly, could you please fill in the details of platform, steps to repro, etc.?

Comment 1

18 years ago
Works fine with SW 8.0. Let me check with 8.5.
Summary: netlanski movie (netling) returns incorrect value for getNextText, error 4836 → netlanski movie (netling) returns incorrect value for getNextText, error 4836

Comment 2

18 years ago
Umm...tried this with SW8.5_full_no_ping (latest SW version) on today's branch 
build on windows and this works perfectly fine with the following results:

netID =2
netDone =1
netError =OK

(Assignee)

Comment 3

18 years ago
Although the netling movie returns OK status for me, other movies return 
different codes with Nav 4.x, IE 5, and us.

Updated

18 years ago
Keywords: 4xp
(Reporter)

Comment 4

18 years ago
Escalating severity to blocker as this bug is blocking Macromedia QA from going 
through their test suite and possibly identifying additional bugs we may yet be 
unaware of. Marking shockwave.
Severity: normal → blocker
Keywords: shockwave
(Assignee)

Comment 5

18 years ago
Peter Grandmaison sent an email to Peter L with the following information on 
12/1:

Anyways, I can unfortunately reproduce the netlingo bug (error code 4836 comes 
up instead of OK) ... however, I spent an hour in the debugger, and I know why 
this doesn't work !

The cgi stream is of unknown length, so in NPP_NewStream() Netscape 6 is 
passing in a stream length of 0xffffffff, wherease Netscape 4.7 (and IE) pass 
in a stream length of 0x00000000. I made a test build which replaces 0xffffffff 
with 0 and the movie works fine.

This solution would presumably fix other streaming bugs.

I'm steeling this one.
Assignee: av → peterlubczynski
OS: Windows NT → All
(Assignee)

Comment 6

18 years ago
Well, now I know why this worked for us and not for Macormedia. Here are Peter 
Grandmaison's comments from e-mail:
------------------------------------
(1) When you browse to 

     http://poppy.macromedia.com/netlanski/files/Netlingo/netlingdcrDoc.html

and try to getNetText of 

     http://elmo.macromedia.com/netlanski/bin/oblique.cgi

I suspect you get different results from someone at macromedia because the 
server elmo is behind our firewall. I expect you get a neterror of ok, but if
you click on 'nettextresult' you will get some form html for a non-existing url.

If you change the domain of the url to poppy, that is, 

     http://poppy.macromedia.com/netlanski/bin/oblique.cgi

you should see the 4836 error we are talking about.
(Assignee)

Comment 7

18 years ago
Created attachment 20214 [details] [diff] [review]
patch that sets length to 0 (instead of -1) if length is unknown

Comment 8

18 years ago
sr=buster

Comment 9

18 years ago
a=av
(Assignee)

Comment 10

18 years ago
patch checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
verified on windows trunk.(1212). Cannot verify on mac trunk unless the bug for 
keyboard events on mac gets fixed (i cannot edit the domain name)

Comment 12

18 years ago
for the record: the key events bug is
http://bugzilla.mozilla.org/show_bug.cgi?id=58957
 for the mac.

Comment 13

18 years ago
Adding branch accept to the status whiteboard.  Peter, please check in on the 
branch ASAP. Thx
.Angela...
Whiteboard: [branch accept]

Comment 14

18 years ago
reopening to get verified on branch after patch is checked in.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 15

18 years ago
Patch checked into branch. Marking FIXED.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
can't verify unless bug 58957 is fixed.
Depends on: 58957

Comment 17

18 years ago
verified on mac trunk an branch (0117). Movie returns OK value for 
getNextText.Marking VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.