Closed Bug 595786 Opened 9 years ago Closed 3 years ago

Remember Password dialog usability issue: "Never for this site" is hard to find

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1282768

People

(Reporter: prasad, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre

Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre

Reproducible: Always

Steps to Reproduce:
1.Loaded a page with login details
2.Entered Username/Password
3.Remember Password dialog comes up




Observed Behavior: I did not want the browser to store my login details.

At first instant I could not realize the drop-down arrow which has the option "Never for this site" and thus used ESC key sequence to cancel the dialog - Usability issue
And felt there is no such option to Cancel.

Maybe this dialog can have a separate button to "Cancel"
I don't intend this as a "me too", but the doorhanger notifications for the password manager on Linux are also difficult to use.

The down arrow on the left of the "Remember" button seems to imply that this is a combobox of some kind, but in fact, clicking the button will Remember your password. Okay, so I tried clicking button and holding - nothing, and when my finger slipped it remembered the password.

I did learn eventually that the down arrow gave me a menu, but the target is small, and there is nothing to visual distinguish exactly where the boundary is between "Never store sensitive data" and "Store sensitive data right now."
Confirming -- seems very odd that "Never Remember Password for this site" would be hidden in a dropdown-menu inside of a big "Remember Password" button.

Discoverability there is pretty tough.  Users who don't want Firefox to remember their passwords are going to be hesitant to click a big "Remember My Password" button.  (when really, that's what they have to do to make it *not* remember their password)

Also, as Erik says in comment 1, the button is sort of a "70% button / 30% combobox" -- not something that users are used to interacting with.  Only the very right edge of it will open the menu.  The rest of it performs an action the user may *not* want firefox to perform.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: Remember Password dialog usability issue → Remember Password dialog usability issue: hard to find
Version: unspecified → Trunk
Summary: Remember Password dialog usability issue: hard to find → Remember Password dialog usability issue: "Never for this site" is hard to find
No longer blocks: 588309
Depends on: 588309
Theme work in bug 577927 should make the button into a more obvious split button. Mock-ups are here: http://www.stephenhorlander.com/images/blog-posts/geolocation-icon/new-style-panels-2.png.

I'm cc'ing faaborg and shorlander, since they've been doing the ux work related to this.
(In reply to comment #3)
> Theme work in bug 577927 should make the button into a more obvious split
> button. Mock-ups are here:
> http://www.stephenhorlander.com/images/blog-posts/geolocation-icon/new-style-panels-2.png.
> 
> I'm cc'ing faaborg and shorlander, since they've been doing the ux work related
> to this.

This is probably a dupe of 581193. Bug 573599 might also be relevant.
I don't think it's going to get any better than bug 1282768.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1282768
You need to log in before you can comment on or make changes to this bug.