Closed Bug 595927 Opened 9 years ago Closed 7 years ago

Tab switching is very slow with Firefox 4 betas

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: hunyadym, Unassigned)

Details

(Keywords: perf, regression, Whiteboard: [Input])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre

Tab switching with Firefox 4 betas is very slow if I have a lot of tabs (5-6 or more). After I click to a tab, it takes sometimes more than a second to switch. When I close the current tab, the tab focus (and the page content) first jumps to an other tab after about a second, but the old tab (which I closed) only disappears after 2-3 seconds later.

I tried it in safe mode and with a new, empty profile too, and in both cases the problem exists. I also tried to disable hardware acceleration, but it didn't help.

With Firefox/3.6.9 I don't have such problems with 15-20 opened tabs, so I don't think that my computer is too slow.

Similar bug is Bug 594197.

Reproducible: Always

Steps to Reproduce:
1. Open a lot of tabs (about 5 or more)
2. Switch between tabs / Close a tab
Actual Results:  
Tab switching is very slow

Expected Results:  
Tab switching should be fast

Graphic informations from about:support:

Adapter Description: ATI RADEON 9600 Series (Microsoft Corporation - WDDM) 
Vendor ID: 1002
Device ID: 4150
Driver Version: 8.56.1.15
Driver Date: 4-24-2009
Direct2D Enabled: false
DirectWrite Enabled: false
GPU Accelerated Layers Enabled: 0/1
(In reply to comment #0)
> I also tried to disable hardware acceleration, but it didn't help.

Only by Disabling the Checkbox in Tools/Options/Advanced/General or also by explicitly setting "layers.accelerate-none" to "true"?
Version: unspecified → Trunk
What's the first beta you see this with?
Now I tried with "layers.accelerate-none" too, but it didn't help. I don't know exactly what beta caused the problem; I am certain, that it was a problem with beta4pre, and probably with beta3pre too.
OK.  Again, since you're the only one who seems to be able to reproduce this, would you be willing to narrow down when the problem appeared?
A lot of users are reporting this issue via Input on Windows 7 - http://input.mozilla.com/en-US/search/?product=firefox&sentiment=sad&date_end=&date_start=&version=&q=tab+switch+slow
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Input]
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594197
Whoops, this has nothing to do with hardware acceleration.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Hunyady, can you reproduce your Issue with a more recent Beta or (preferably) with a recent Nightly Build?
http://nightly.mozilla.org/
(In reply to comment #8)
> Hunyady, can you reproduce your Issue with a more recent Beta or (preferably)
> with a recent Nightly Build?
> http://nightly.mozilla.org/

Yes. I tried "Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101211 Firefox/4.0b8pre".

It takes sometimes about 1-2 seconds to close, open or switch tab, while Firefox 3.6 with the same opened tabs does it immediately (even if both of them opened in the same time, 3.6 is quick, 4 nightly is very slow).

I installed another Windows 7 to the same computer, and I have the same problem on this new OS too.
Can you give a Sample of Sites somebody has to open in several Tabs to see the Issue?
For example: Gmail, Google Reader, Google Calendar, WolframAlpha, 2 Wikipedia pages. But none of them necessary, it happens after opening about 5-6 pages (sometimes more, or less if I open e.g. YouTube).

But the problem doesn't occur on every computer, e.g on my laptop it's quick (but with WinXP, less memory and slower CPU).
(In reply to comment #11)
> For example: Gmail, Google Reader, Google Calendar, WolframAlpha, 2 Wikipedia
> pages. But none of them necessary, it happens after opening about 5-6 pages
> (sometimes more, or less if I open e.g. YouTube).
> 
> But the problem doesn't occur on every computer, e.g on my laptop it's quick
> (but with WinXP, less memory and slower CPU).
Does this still occur on the latest nightly?

If so, would you be able to try and find the regression range?
https://wiki.mozilla.org/QA/Triage#How_to_Help_with_Regressions_--_Finding_Regression_Windows
Hunyady, is this still an Issue for you using a recent Nightly or Fx 4.0.1?
Sorry for the slow answer, I used another computer recently.
Yes, it still occurs sometimes, both with Firefox 4.0.1 and with the latest Nightly (Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110523 Firefox/6.0a1)
(In reply to comment #14)
Ok, sorry to hear that. If you can spend some Time you can help by finding the first Nightly showing the Issue:
http://harthur.github.com/mozregression/
I've tried now the latest Nightly (8.0a1 (2011-08-02)), and it's much better, than the version I've used earlier (7.0a1 (2011-06-??)), but sometimes it's still lagging.
I will try to find the regression later, but I don't have time now to work with it.
bug 743877 may have fixed this, please retry in 15a nightlies.
Without a regression window or a profile this bug is useless.
Hunyady, will you be able to find a regression window or use the built-in profiler? (https://developer.mozilla.org/en-US/docs/Performance/Profiling_with_the_Built-in_Profiler#Running_the_profiler)
Otherwise, I think this bug is useless and can be closed.
Unfortunately, I no longer have the computer on which the problem occured, so I can't reproduce the problem. Sorry about that.
Status: REOPENED → RESOLVED
Closed: 9 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.