mail crashes on second never read folder

VERIFIED FIXED

Status

P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: axel, Assigned: sspitzer)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
There is a small bug in nsLocalStringService::GetBundle that produces a crasher
on all but the first call of this function.
Well, it doesn't return the stringbundle, so not checking the return will crash.
nsMsgMailboxParser::UpdateStatusText does so.

In
http://lxr.mozilla.org/seamonkey/source/mailnews/local/src/nsLocalStringBundle.cpp#70
nsresult rv;
should read
nsresult rv = NS_OK;
as for a uninitialized rv, the NS_ENSURE_SUCCESS(rv,rv) failes otherwise,
and we don't return the cached mLocalStringBundle.

Axel

Comment 1

18 years ago
Assigning to kin, who knows about this problem. Thanks!
Assignee: sspitzer → kin
I've got this fix for this, and another one in the msg compose string bundle code.

I'll land them as soon as the tree opens.

taking from kin.
Assignee: kin → sspitzer

Comment 3

18 years ago
Seth, could you add an attachment to this bug with the diffs please?
We (Sun) will want to apply them to our RTM/FCS release as well. Thanks.
accepting.  I'll attach the patch now.
Status: NEW → ASSIGNED
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Blocks: 60740

Comment 7

18 years ago
The same fix has been checked in into the OEM branch: Netscape_6_0_OEM_BRANCH.
a=jdunn@netscape.com.

Comment 8

18 years ago
Changing qa assign
QA Contact: esther → pmock

Comment 9

18 years ago
*** Bug 58916 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
Verified as fixed on win32, linux, and macos using the following builds:
 win32 commercial seamonkey build 2000-121809-mtrunk installed on P500 Win98
 linux commercial seamonkey build 2000-121808-mtrunk installed on P200 RedHat 
6.2
 macos commercial seamonkey build 2000-121808-mtrunk installed on G3/400 OS 9.04
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
*** Bug 61752 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.