If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla only gets e-mails in plain text , not HTML, from Exchange server

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
P2
normal
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Erik Talvola, Assigned: Scott MacGregor)

Tracking

Trunk
mozilla1.2alpha
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: outlook)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
(re-entered from Bug 59556 which was marked INVALID because I stuck about 3 or 
4 things in the same entry)

E-mails from Outlook 98 (at least the way we have it set up at work here) send 
by default e-mail messages which are multi-part messages with a text/plain 
version of the message, and a text/html version of the message, for example:

first part:

------_=_NextPart_001_01C049E5.C7923480
Content-Type: text/plain;
        charset="iso-8859-1"

second part:

------_=_NextPart_001_01C049E5.C7923480
Content-Type: text/html;
        charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

As far as I can tell, Netscape Mail will only let me read the text/plain 
version of the e-mail, and won't let me view the text/html version.  (This is 
in a Mozilla build of 7-NOV-2000 or so)

What I'd like to see, in a case like the above e-mail, is that Mail lets me read
it in either plain text format, or HTML format - if the mail is in multiple
formats, why not let the user choose?  Or, set up some preferences to allow the
user to specify things.

Bug 40572 talks about converting incoming HTML e-mail to plain text. Bug 18427
is also similar.

Comment 1

17 years ago
Changing qa assign
QA Contact: esther → pmock

Comment 2

17 years ago
Reporter is this still a problem in the latest nightlies?
(Reporter)

Comment 3

17 years ago
Using the version in /pub/mozilla/nightly/2000-12-18-09-Mtrunk - 2000121804 - 
this is still happening.

All messages I read from the Exchange server here only display in text mode, 
and there seems to be no indication that there is an HTML version.  Doing 
a 'View Source' only shows the text/plain version.

Here is more detail of the e-mail if it helps:

From: Erik Talvola <talvola@yahoo.com>
To: "'talvola@sdf.lonestar.org'" <talvola@sdf.lonestar.org>
Subject: Geek Lunch Presents:
Date: Mon, 27 Nov 2000 12:34:51 -0500
Content-Type: multipart/alternative;
        boundary="----_=_NextPart_001_01C05898.69A6886E"

This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.

------_=_NextPart_001_01C05898.69A6886E
Content-Type: text/plain;
        charset="iso-8859-1"

(blah blah)

------_=_NextPart_001_01C05898.69A6886E
Content-Type: text/html;
        charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
5.5.2650.12">
<TITLE>Blah: </TITLE>
</HEAD>
<BODY> 
(blah blah)
</BODY>
</HTML>
------_=_NextPart_001_01C05898.69A6886E--  

Comment 4

17 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
nominating mail3.  It would help if you could create an email that you don't
mind posting publicly and then add it as an attachment.
Keywords: mail3
(Reporter)

Comment 6

17 years ago
OK - here goes.  I'm away from work for a few days, but this should work as an 
example.  This was an e-mail forwarded from work (using Outlook 98) to a shell 
account - I copied the text in the next attachment from an Emacs RMAIL buffer.

It's pretty much as I described before - MIME 'multipart/alternative' message 
with a text/plain version first, and then a text/html version afterwards.  
(Reporter)

Comment 7

17 years ago
Created attachment 21259 [details]
Test case for multipart text/html email

Comment 8

17 years ago
Your attachment can't be viewed as an email.  Could you please create a new
local folder, copy the message into that folder and then attach the folder to
this bug.
Thanks, Esther
(Reporter)

Comment 9

17 years ago
I'm probably just dense, but I'm not sure what I need to attach here, or how to.

If I view the e-mail in Mozilla - I never see anything but a text/plain 
message.  The only way I can see the multi-part e-mail is by reading the e-mail 
with some other reader, like Emacs RMAIL (which I did) and cutting and pasting 
the results.  If I View Message Source or save the e-mail as a file, I always 
get a text/plain.

I suspect that the problem is when Mozilla fetches the message from the 
Exchange server.  I have seen multi-part messages of a similar sort which 
display fine from Yahoo Mail (using POP3 I believe), but everything from the 
Exchange server (using IMAP) comes out as text/plain - I never see HTML 
messages.

I'm not sure how to send a test file - it may require someone at Netscape to 
have access to an Exchange server, which I can't provide.  Or, again, let me 
know what else I could do to help.

Let me know what I should do differently - I could just forward the e-mail to 
someone directly if that helps.

Comment 10

17 years ago
I don't see any html part in your attachment.  It sounds like you have a
different mail reader.  Just go to that and get the mail from there and then
create an attachment in this bug.

Comment 11

17 years ago
reassigning to ducarroz.
Assignee: putterman → ducarroz

Comment 12

17 years ago
marking nsbeta1-
Keywords: nsbeta1-

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.7

Updated

16 years ago
Whiteboard: outlook

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.9

Updated

16 years ago
Keywords: mail3 → nsbeta1+
Using today's build on Window, I don't have problem displaying correctly the
test message. Only the HTML part show up! WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

16 years ago
The issues isn't Mozilla's handling of the multipart e-mails, despite the 
summary.  The issue is what I had mentioned in the 12/18/2000 comment - Mozilla 
when fetching e-mails from (at least) a Microsoft Exchange mailserver only gets 
the text version of the e-mail - it doesn't get the multipart message.  A view 
source on the message in the attachment below shows:

Received: by sfccmsx01.sapient.com 
	id <01C16E15.B0B22CC0@sfccmsx01.sapient.com>; Thu, 15 Nov 2001 
12:39:58 -0800
Message-ID: <A4EBF226E82C984AAA757749B77719180689F7@sfccmsx01.sapient.com>
From: Erik Talvola <etalvola@sapient.com>
To: Erik Talvola <etalvola@sapient.com>
Subject: Test message
Date: Thu, 15 Nov 2001 12:39:57 -0800
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"

This message sent from Microsoft Outlook 2000.   Format is 'Rich Text'
in Outlook.

20 point Courier in blue

11 point Tahoma in green



with no multi-part info.   Somehow, Outlook is able to get that info, but 
Mozilla is not.  Note that I just tried Eudora, and it doesn't work either, so 
this is probably something strictly on the IMAP/network end of things.
(Reporter)

Comment 15

16 years ago
Created attachment 57989 [details]
Screen shot of Mozilla displaying the e-mail

Here's what it looks like in Mozilla
(Reporter)

Comment 16

16 years ago
Created attachment 57992 [details]
Correct display in Outlook

This is how the message displays in MS Outlook 2000.
Reopen... We need a better summary!
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

16 years ago
Summary: Multipart e-mails with both text and HTML versions only display the text version → Mozilla only gets e-mails in plain text , not HTML, from Exchange server

Updated

16 years ago
Priority: P3 → P2

Updated

16 years ago
QA Contact: pmock → esther
(Reporter)

Comment 18

16 years ago
I've been told (but don't know how to confirm) that when you use IMAP to fetch
messages from an Exchange server - this is all you get.  You have to use the
MS-specific APIs (MAPI?) to fetch messages that include HTML, etc.

Comment 19

16 years ago
Karen, are you able to reproduce this?
QA Contact: esther → huang

Comment 20

16 years ago
IMAP log could help here, I think :-)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0
looks like an IMAP issue and not a mime problem. Reassign...
Assignee: ducarroz → mscott
Status: REOPENED → NEW
Component: Mail Window Front End → Networking - IMAP

Comment 22

16 years ago
nsbeta1- as per ADT
Keywords: nsbeta1+ → nsbeta1-

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.2
(Reporter)

Comment 23

16 years ago
From what I understand, this will be a different solution for Exchange Server 
5.5 and Exchange Server 2000.  5.5 uses a proprietary API (MAPI?) for 
communications, whereas 2000 uses WebDAV, or some variant.  Even though it's 
for another product, Ximian now offers a connector which allows reasonably full 
functionality with Exchange Server 2000 and Evolution - 
http://www.ximian.com/about_us/press_center/press_releases/connector_launch.html
 for more details.

Updated

15 years ago
QA Contact: huang → gchan

Comment 24

14 years ago
I'm experiencing the same problem.  When I get messages from an Exchange IMAP
server, it comes out as plain text with all the HTML formatting visible.  When
viewed under Outlook 2000, it shows normally.

Comment 25

14 years ago
Created attachment 126754 [details]
Snapshot of email in Outlook 2000

This is how the email looks in Outlook 2000

Comment 26

14 years ago
Created attachment 126755 [details]
Snapshot of email in Moz 1.4 rc2

This is how the email looks in Moz 1.4 rc2, looking at the same email in the
same folder on the Exchange server.

Comment 27

14 years ago
I am seeing the exact same thing unchanged even in 1.5.

multi-part html messages sent from mozilla to exchange users running outlook -
no problem
multi-part html messages sent from outlook to exchange users running outlook -
no problem
multi-part html messages sent from mozilla to exchange users running mozilla -
no problem
multi-part html messages sent from outlook to exchange users running mozilla -
only the plain/text portion seems to arrive.

Searching around on the web I found suggestions that outlook is not well behaved
and munged the mail headers which seems just typical for MS to do. 

Comment 28

14 years ago
I am seeing the exact same thing unchanged even in 1.5.

multi-part html messages sent from mozilla to exchange users running outlook -
no problem
multi-part html messages sent from outlook to exchange users running outlook -
no problem
multi-part html messages sent from mozilla to exchange users running mozilla -
no problem
multi-part html messages sent from outlook to exchange users running mozilla -
only the plain/text portion seems to arrive.

Searching around on the web I found suggestions that outlook is not well behaved
and munged the mail headers which seems just typical for MS to do. 

Product: MailNews → Core
(Reporter)

Comment 29

10 years ago
In the latest 2.0.0.6 Thunderbird, Exchange Server messages seem to be displaying properly - I haven't compared side-to-side with Outlook, but I think we can close this and replace it with more specific bug reports if something surfaces.
Status: NEW → RESOLVED
Last Resolved: 16 years ago10 years ago
Resolution: --- → FIXED

Comment 30

10 years ago
No bug or patch referenced as the fix.

-> WORKSFORME
Resolution: FIXED → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.