Closed Bug 596338 Opened 9 years ago Closed 9 years ago

Undefined symbol js::JMCheckLogging

Categories

(Core :: JavaScript Engine, defect)

PowerPC
All
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mnyromyr, Assigned: ginnchen+exoracle)

References

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(2 files, 1 obsolete file)

Well, I know PPC isn't supported officially anymore, but maybe OpenSolaris is again affected...

Building today's SeaMonkey (debug) trunk dies with

Undefined symbols:
  "js::JMCheckLogging()", referenced from:
      js::RunScript(JSContext*, JSScript*, JSFunction*, JSObject*)   in jsinvoke.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[5]: *** [libmozjs.dylib] Error 1
make[4]: *** [libs_tier_js] Error 2
make[3]: *** [tier_js] Error 2
make[2]: *** [default] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2
I don't have this problem on Solaris.
I can recreate the problem with SPARC debug build.
Attached patch patchSplinter Review
Assignee: general → ginn.chen
Status: NEW → ASSIGNED
Attachment #476626 - Flags: review?(dvander)
Yep, my Mac is happy again with this patch! :-D
Attachment #476626 - Flags: review?(dvander) → review+
Can we get this checked in, please? :) 
(I could do, if necessary.)
Duplicate of this bug: 618242
http://hg.mozilla.org/tracemonkey/rev/cec3c87c99b1
OS: Mac OS X → All
Whiteboard: fixed-in-tracemonkey
This broke --disable-methodjit builds (not yet visible on tbpl.m.o, but visible on http://dev.philringnalda.com/tbpl/?tree=TraceMonkey and tinderbox.m.o) - is that maybe missing something like a "|| defined JS_TRACER" at the end?
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
http://hg.mozilla.org/tracemonkey/rev/e3c6960a4868 fixed building with --no-methodjit on x86, but this bug appears again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: fixed-in-tracemonkey
Attached patch patch v2 (obsolete) — Splinter Review
try again, tested on SPARC and x86 with no methodjit
Attachment #512725 - Flags: review?(wmccloskey)
Attached patch another ideaSplinter Review
Sorry I broke your patch.

I looked this over carefully. As far as I can tell, the problem is that we need Logging code both for the methodjit and for YARR. On Sparc and PPC, we don't have either. On x86, --disable-methodjit seems to leave YARR turned on.

Could you try this patch instead? I think it's a little cleaner. It works in both modes for me on x86. I don't have access to Sparc or PPC though.
(In reply to comment #13)
> I looked this over carefully. As far as I can tell, the problem is that we need
> Logging code both for the methodjit and for YARR. On Sparc and PPC, we don't
> have either. On x86, --disable-methodjit seems to leave YARR turned on.

I know it's not everybodies favourite solution, but bug 633702 is one solution (combining the methodjit and yarr flags).
(In reply to comment #13)
> Created attachment 512879 [details] [diff] [review]
> another idea
> 

Works for me on SPARC, thanks!
Attachment #512879 - Flags: review?(ginn.chen) → review+
Attachment #512725 - Attachment is obsolete: true
Attachment #512725 - Flags: review?(wmccloskey)
http://hg.mozilla.org/mozilla-central/rev/cf342441a8d5
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.