Closed Bug 596361 Opened 11 years ago Closed 11 years ago

Some windows aren't properly created if their initial position is offscreen

Categories

(Core :: Widget, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 598673
Tracking Status
blocking2.0 --- final+

People

(Reporter: erikvvold, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre

I did this: http://twitter.com/erikvold/status/24506895876
Then this happened: http://twitter.com/erikvold/status/24506987588

Reproducible: Always

Steps to Reproduce:
1. On Gecko/20100913 Firefox/4.0b6pre do this: http://twitter.com/erikvold/status/24506895876
2. Try to open the error console
Actual Results:  
Nothing happens

Expected Results:  
Error console should open
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583476
Not a dup. Bug 583476 is about the HUD Web Console, this one is about the Chrome Error Console.
Status: RESOLVED → REOPENED
Component: Developer Tools → Menus
Ever confirmed: true
QA Contact: developer.tools → menus
Resolution: DUPLICATE → ---
Depends on: 596249
WFM, did you try to use the key command or the menu item?
This is working now for some reason, when it wasn't working it was just for one profile, and I tried a couple of others and those worked, eventually rebooted and now it's working. Anyhow I can't reproduce this now so I'll close.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → WORKSFORME
I tried the menu item
Have you eventually used Panorama during that session?
I had a problem with the Error Console in one of my testing profiles. Console would not open via menu or keyboard shortcut. Creating a new profile fixed the issue. Seems like there might be something here.
also, I noticed this inability to open the Error Console before the patch landed in bug 593538.

Reopening as unconfirmed. I'd like a test-case that shows how this happens.
Status: RESOLVED → UNCONFIRMED
Component: Menus → Error Console
Ever confirmed: false
Product: Firefox → Toolkit
QA Contact: menus → error.console
Resolution: WORKSFORME → ---
(In reply to comment #6)
> Have you eventually used Panorama during that session?

no
I had this problem for a time, I also saw the download manager wouldn't open for a while too. Both of them resolved themselves after a while though.
from a discussion in IRC, I was pointed to localstore.rdf in my profile.

  <RDF:Description RDF:about="chrome://global/content/console.xul#JSConsoleWindow"
                   sizemode="normal"
                   screenX="-1449"
                   screenY="563"
                   width="3383"
                   height="332" />

sure enough, these values are out-of-bounds and suggested what I did to cause it:

1. Open the Error Console.
2. Move the Error Console to the left of the screen and make it wider using the resizer.
3. Repeat step 2 moving it left of the screen boundary.
4. Quit Firefox when the console is sufficiently large
5. Restart, open the Error Console

Expected Result:
Error Console should open. What happens, Error Console does not appear.

Let me know if this matches what you're seeing and if possible, relay the contents of the JSConsole's section of localstore.rdf.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I was using a 2nd monitor before this happened, and likely had the error console on the other screen, it wasn't plugged in when I experienced this issue though.
(In reply to comment #12)
> I was using a 2nd monitor before this happened, and likely had the error
> console on the other screen, it wasn't plugged in when I experienced this issue
> though.

I blame hardware:)
I blame our window opening code. Moving to something more widgety.
Component: Error Console → Widget
Product: Toolkit → Core
QA Contact: error.console → general
I've seen this too, and Cww found some other very-likely dupes. It seems that this regressed around the early betas. I got some more info today:

On 3.6 if a window was entirely offscreen it is moved to ensure at least some part of it is visible. On 4.0 this is not happening and, worse, it doesn't have to be entirely offscreen, just to have a negative screenX.

Slightly simpler STR:
 - Ensure that your browser window is not "maximized" (resizing it a bit smaller should suffice)
 - Move window a few pixels offscreen to the left
 - Close window
 - Cmd + N to open window

Results:
  The window does not appear, except on the "Window" menu. Selecting it on the menu has no effect (for example, the options "Close Tab" and "Close Window" does not appear on the "File" menu)

To get out of this situation, open a few more windows using Cmd+N until one of them appears onscreen, or change the negative screenX value on localstore.rdf
blocking2.0: --- → ?
Summary: Error Console does not open → Some windows aren't properly created if their initial position is offscreen
Sounds good, Felipe. Pretty sure this should block final release as it's very confusing if you manage to do this accidentally.
Dup'ing forward as bz bisected the regression range on the other bug
Status: NEW → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598673
You need to log in before you can comment on or make changes to this bug.