If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clicking checking box for ToS doesn't activate Continue button in account setup dialog

NEW
Unassigned

Status

Cloud Services
Firefox Sync: UI
P5
minor
7 years ago
6 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Seen on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre  

The bug is *not* present on the equivalent Win 7 build.

1) proceed through the account setup dialog for a new account
2) when you have finished typing your email, click the check box for the ToS and PP

Tested result:
The continue button does not become active

Expected result:
The continue button becomes active allowing you to proceed.

Note: work around is to, after step 2, manually move focus away from the email entry field. For instance, by clicking in the username field.
I can reproduce this. At first I thought I couldn't but then I figured out why: you have to click on the checkbox itself. If you click on the text next to checkbox, it actually works.
Right, because that shifts the focus and causes the validation to happen on the email.
FWIW, this issue is less of a problem since the email address field was moved to the top of the wizard in bug 589979 (or bug 595066 for the integrated Firefox UI). It's still something we need to fix, not only with the email address but also with the custom server field.

I wonder if we really have to disable the Continue/Next button. I find it nicer to keep it enabled and not just advance in case of an error.

Updated

6 years ago
Severity: normal → minor
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.