Vimeo's embedded Flash player can not play with Minefield UA or "pre" version numbers

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Yansky, Unassigned)

Tracking

({regression})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

After clicking on the play button on the embedded vimeo flash video, nothing happens. It seems to work ok in Firefox 3.6.9 though.

Reproducible: Always

Steps to Reproduce:
1. Go to http://berglondon.com/blog/2010/09/14/magic-ipad-light-painting/
2. Click on the play button on the flash video
3. Nothing happens
Actual Results:  
Flash video does not play.

Expected Results:  
Flash video to play.

I'm not sure if this is relevant, but when the page loads, it produces this error in the error console:

Error: Error setting property on NPObject!
Source File: http://a.vimeocdn.com/js/player_combined.opt.js?89300
Line: 39

Comment 1

8 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100924 Firefox/4.0b7pre

I confirm it happens with every embedded flash videos from Vimeo I tried, but not with the youtube ones.

For me,the error is :
Error: Trying to add unsupported property on NPObject!
Source File: http://a.vimeocdn.com/js/player_combined.opt.js?648d8
Line: 39 

In FF 3.6.10, it works but there is also an error :
Error: Permission denied for <http://player.vimeo.com> to get property Location.toString from <http://berglondon.com>.
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → plugins
Summary: Flash video embedded using iframe unable to play → Vimeo's embedded Flash player can not play
Version: unspecified → Trunk

Comment 2

8 years ago
It also happens on Linux, I can see the controls and hear the sounds during playback, but the video is not reproduced.

Mozilla/5.0 (X11; Linux i686; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Comment 3

8 years ago
Created attachment 478635 [details]
Screen with black video

Updated

8 years ago
OS: Windows XP → All

Comment 4

8 years ago
Regression window for Windows 7:
Works:
http://hg.mozilla.org/mozilla-central/rev/bb9d266da12c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100826 Minefield/4.0b5pre ID:20100826222935
Fails
http://hg.mozilla.org/mozilla-central/rev/e1d55bbd1d1d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100827 Minefield/4.0b5pre ID:20100827010837
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb9d266da12c&tochange=e1d55bbd1d1d


WORKAROUND is as follows:
In Windows 7:
If I set "general.useragent.override" to 
"Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100915 Firefox/3.6.10",then the Flash movie works well.

In Linux,
If I set "dom.ipc.plugins.enabled" to false *AND* "general.useragent.override" to  "Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.2.10) Gecko/20100915 Ubuntu/8.04 (hardy) Firefox/3.6.10", then the Flash movie works well.

I think this is combination of the Site issue and IPC bug in Linux.
OS: All → Windows XP

Comment 5

8 years ago
(In reply to comment #4)
> Regression window for Windows 7:
> Works:
> http://hg.mozilla.org/mozilla-central/rev/bb9d266da12c
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100826
> Minefield/4.0b5pre ID:20100826222935
> Fails
> http://hg.mozilla.org/mozilla-central/rev/e1d55bbd1d1d
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100827
> Minefield/4.0b5pre ID:20100827010837
> Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb9d266da12c&tochange=e1d55bbd1d1d
> 
> 
> WORKAROUND is as follows:
> In Windows 7:
> If I set "general.useragent.override" to 
> "Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100915
> Firefox/3.6.10",then the Flash movie works well.
> 
> In Linux,
> If I set "dom.ipc.plugins.enabled" to false *AND* "general.useragent.override"
> to  "Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.2.10) Gecko/20100915
> Ubuntu/8.04 (hardy) Firefox/3.6.10", then the Flash movie works well.
> 
> I think this is combination of the Site issue and IPC bug in Linux.

I just set general.useragent.override to Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 and video started working, without without switching off OOPP, so definely definitely it's only an user agent "problem".

Comment 6

8 years ago
oops sorry for the double words...

Updated

8 years ago
Depends on: 581008
Sounds like an evangelism bug off-hand, since sites out there need to fix themselves to be compatible with the new UA, but I'm confused as to how it could be a regression from UA string bug, specifically bug 581008, since there's no arbitrary data in the "working" build's string in comment 4 (nor are there any differences between working and broken builds' UA strings, aside from the buildid).

Comment 8

8 years ago
It is strange because for me 4.0b5pre/20100826 build fails. If I scan older builds, 3.7a1pre/20100101 also fails. So the regression range is older than the one in comment 4.
My version of Flash plugin is 10.1.82.76.

Comment 9

8 years ago
Oddly, with https://bugzilla.mozilla.org/show_bug.cgi?id=599476 patch it seems fixed on linux.

Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20101002 Firefox/4.0b7pre

Comment 10

8 years ago
(In reply to comment #8)
> It is strange because for me 4.0b5pre/20100826 build fails. If I scan older
> builds, 3.7a1pre/20100101 also fails. So the regression range is older than the
> one in comment 4.
> My version of Flash plugin is 10.1.82.76.

At least you should spoof UA Minefield to Firefox to check regression range.

Failed pattern are 
"Minefield/3.6.1"
"Firefox/3.7a1pre"

Success pattern is "Firefox/3.6.x"

After landing Bug 581008, UA is Firefox/4.0b5pre" and the site fails.


Any way this is *Site issue*.

Updated

8 years ago
Duplicate of this bug: 615835

Updated

8 years ago
Assignee: nobody → english-us
Component: Plug-ins → English US
Product: Core → Tech Evangelism
QA Contact: plugins → english-us
Version: Trunk → unspecified

Updated

8 years ago
Summary: Vimeo's embedded Flash player can not play → Vimeo's embedded Flash player can not play with Minefield UA or "pre" version numbers

Comment 12

8 years ago
Do "pre" version numbers include beta version?
Because it does not work in Firefox 4.0b7.

Comment 13

8 years ago
I don't know. What happens if you spoof the useragent to say Firefox 4.0, or Firefox 3.6?

Comment 14

8 years ago
> I don't know. What happens if you spoof the useragent to say Firefox 4.0, or
> Firefox 3.6?
It works in FF 3.6.
The "User agent switcher" extension is not compatible with FF 4.0b7. But if I set general.useragent.compatMode.firefox to true, it adds one more "Firefox/4.0b7" to my UA string after a restart and the issue still exists in FF 4.0b7.
My current UA string is: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

Comment 15

8 years ago
You should be able to set the general.useragent.override pref to spoof the 2.0/4.0 final UA string, or spoof the old Firefox 3.6 UA string.

Comment 16

8 years ago
> You should be able to set the general.useragent.override pref to spoof the
> 2.0/4.0 final UA string, or spoof the old Firefox 3.6 UA string.
In FF 4.0b7, I set my UA string to:
* Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0 and it does not work.
* Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0 and it does not work.
* Mozilla/5.0 (Windows NT 6.1; rv:1.9.2.12) Gecko/20100101 Firefox/3.6.12 and it works.

So this Vimeo's embedded player can only play if there is 3.6 in UA string. The bug title must be renamed to reflect that.
If I try 3.6.12, works. 

If I try latest nightly (which normally doesn't work), but set user agent to include Firefox/3.6.12, works.

However, if I leave the user agent set to default and try regression range finding using Minefield nightlies & clean profiles each time, I get:

Last good nightly: 2009-10-31
User agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091031 Minefield/3.7a1pre)

First bad nightly: 2009-11-01
User agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091101 Minefield/3.7a1pre

Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7e0336a4f6fd&tochange=736619af9701

So it would appear that:
- Works if user agent given is for 3.6.x
- Works if user agent is for 3.7a1pre as long as using a nightly before 2009/11/01

Presume the second case above is also due to bad Vimeo code (even though it contains "pre", which is supposed to break it), but adding this in case it helps the tech evang, or if other people find the different regression range and wonder what is going on.

Comment 18

8 years ago
This wouldn't be the first time someone had outsmarted themselves with date-specific UA sniffing. (See, for example, bug 471816 and bug 410430.)

It is a little unusual for the sniffing to be *that* specific, though.

cl
It seems that videos are now working with latest trunk.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101216 Firefox/4.0b9pre

Comment 20

8 years ago
It works also in Firefox 4.0b7.
So thanks to Tech evangelists.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 21

8 years ago
Someone should test this with something besides Firefox, too.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.