TryServer build failures with "make: client.mk: No such file or directory" (and changeset ID missing in the failure email)

RESOLVED DUPLICATE of bug 595027

Status

RESOLVED DUPLICATE of bug 595027
8 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Filing this bug for some TryServer failures I just hit, built from this changeset:
http://hg.mozilla.org/try/rev/b38accc8e178

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1284572662.1284577293.30751.gz
WINNT 5.2 tryserver build on 2010/09/15 10:44:22
	
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1284572662.1284577428.31295.gz
OS X 10.5.2 tryserver build on 2010/09/15 10:44:22

Here's the fail-output from the mac log:
{
make -f client.mk build
 in dir /builds/slave/tryserver-macosx/build (timeout 7200 secs)
 watching logfiles {}
 argv: ['make', '-f', 'client.mk', 'build']
 environment:
  Apple_PubSub_Socket_Render=/tmp/launch-xbWsUx/Render
  CHOWN_REVERT=~/bin/chown_revert
  CHOWN_ROOT=~/bin/chown_root
  CVS_RSH=ssh
  DISPLAY=/tmp/launch-YEN80w/:0
  HOME=/Users/cltbld
  LC_ALL=C
  LOGNAME=cltbld
  MOZ_CRASHREPORTER_NO_REPORT=1
  MOZ_OBJDIR=obj-firefox
  PATH=/tools/buildbot/bin:/tools/python/bin:/opt/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
  PWD=/builds/slave/tryserver-macosx/build
  SHELL=/bin/bash
  SSH_AUTH_SOCK=/tmp/launch-ZwBvMj/Listeners
  SYMBOL_SERVER_HOST=dm-symbolpush01.mozilla.org
  SYMBOL_SERVER_PATH=/mnt/netapp/breakpad/symbols_ffx/
  SYMBOL_SERVER_SSH_KEY=/Users/cltbld/.ssh/ffxbld_dsa
  SYMBOL_SERVER_USER=ffxbld
  TINDERBOX_OUTPUT=1
  TMPDIR=/var/folders/TL/TLg3RrMbFAur2hBCXvCeqk+++TM/-Tmp-/
  USER=cltbld
 closing stdin
 using PTY: True
make: client.mk: No such file or directory
make: *** No rule to make target `client.mk'.  Stop.
}

Problem #1 (which I'm most concerned with) is that it's failing to build, with that output. :)

Problem #2 is that the email I got for these failures had no changeset ID -- so I didn't actually know which (if not both) of my 2 recent TryServer pushes had failed (until I went and searched Tinderbox for specific changeset IDs).
> Your Try Server build () failed to complete on win32 on builder: WINNT 5.2 tryserver build.
>
> Visit http://tinderbox.mozilla.org/showbuilds.cgi?tree=MozillaTry to view the full logs.
Those empty parenthesis are supposed to contain the changeset ID.

(The failure also didn't show up on TBPL)
(Reporter)

Updated

8 years ago
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Updated

8 years ago
Summary: TryServer build failure with → TryServer build failures with "make: client.mk: No such file or directory" (and changeset ID missing in the failure email)
The clones of the try repo hit:
 command timed out: 3600 seconds without output
but the build didn't terminate there.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595027
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.