The default bug view has changed. See this FAQ.

Failing hg clone step was green

RESOLVED FIXED

Status

Release Engineering
Other
--
major
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: nthomas, Assigned: bhearsum)

Tracking

Dependency tree / graph
Bug Flags:
needs-treeclosure +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [try])

(Reporter)

Description

7 years ago
A couple of linux64 slaves timed out cloning the try repo 
  command timed out: 3600 seconds without output, killing pid 2734
  elapsedTime=3600.068265
  program finished with exit code -1
but the step was green so the job continued (failing at the very start of compile).

Jobs refs: 
Linux x86-64 tryserver build #2793
Linux x86-64 tryserver leak test #2763

Suspected regression from bug 505512.
(Assignee)

Comment 1

7 years ago
I'll have a look.
Assignee: nobody → bhearsum
(Assignee)

Comment 2

7 years ago
So, the upstream code doesn't check the return code of the command if log_eval_func is set -- this changed mid-development, which is probably why regex_log_evaluator isn't checking the return code. The following upstream changeset will fix us up:
http://github.com/buildbot/buildbot/commit/e8e5bcb7434aa90e2a76423d7ebe3394bd347d00

Requires a Buildbot restart on tm*, pm01 and pm03.
Blocks: 593081
(In reply to comment #2)
> Requires a Buildbot restart on tm*, pm01 and pm03.

Do we need to restart try master as well?
(Assignee)

Comment 4

7 years ago
Yes, good catch!
(Assignee)

Comment 5

7 years ago
Tested this fix in staging today, worked fine:
http://staging-master.build.mozilla.org:8011/builders/WINNT%205.2%20mozilla-central%20nightly/builds/22

Failed to clone build tools, halted there, the step was white.
(Reporter)

Updated

7 years ago
Duplicate of this bug: 596709
(Reporter)

Comment 7

7 years ago
It'd be great if we could have buildbot return 'version-rev' for 'buildbot --version', where rev is the revision of the code in our buildbot repo. I think that should be as easy as modifying master/buildbot/__init__.py after landing any changes.
(Assignee)

Updated

7 years ago
Flags: needs-treeclosure+
(Assignee)

Updated

7 years ago
Duplicate of this bug: 600337
(Assignee)

Comment 9

7 years ago
This landed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.