Email deleted on IMAP server and search index

RESOLVED DUPLICATE of bug 571421

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 571421
8 years ago
8 years ago

People

(Reporter: Mahesh Asolkar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.11pre) Gecko/20100916 Lightning/1.0b3pre Lanikai/3.1.5pre

When I search for something in Thunderbird (Lanikai) it returns results as expected. But when I click on some of the results, the message does not exist. This mostly happens with old messages that have been automatically deleted on the IMAP (Exchange) server.


Reproducible: Always

Steps to Reproduce:
1. In a setup where old Exchange email messages are automatically deleted, set up an IMAP account
2. Let the indexing finish
3. After a few days (or after manually deleting email on server) search something that will result in finding one of the deleted email messages
Actual Results:  
Thunderbird finds the old email correctly, but when you click on it, nothing opens - a blank list appears.

Expected Results:  
When email is deleted on server, search index should somehow catch up. It should not display any search result that it cannot display
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 571421
You need to log in before you can comment on or make changes to this bug.