Hovered link target shown in the location bar isn't dark enough to read

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

({access})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
 1) Get a build from 2010-09-15 or so.
 2) Use the default theme or its color variant on Ubuntu (Ambiance and Radiance) or (reportedly) the default theme of Fedora.
 3) Move the mouse pointer over a link on any Web page.

Actual results:
The link target is shows in light gray in the right end of the location bar. It's too light to read easily.

Expected results:
Expected the text shown on hover in the location bar to be darker.
Blocks: 587908

Updated

9 years ago
Keywords: access

Comment 1

9 years ago
I find this too on Kubuntu 10.04 with default "GTK+ Appearance" of QtCurve + KDE fonts.  Also the arrow feels more prominent than the link target text; I filed bug 597771.

Comment 2

9 years ago
This text's color needs to be set in relation to the current GNOME theme's Background color for Input boxes.  Otherwise, someone with an Input box Background of #B3B3B3 (value of the 'GrayText' color used in browser.css) will not see it at all.
(In reply to comment #2)
> This text's color needs to be set in relation to the current GNOME theme's
> Background color for Input boxes.  Otherwise, someone with an Input box
> Background of #B3B3B3 (value of the 'GrayText' color used in browser.css) will
> not see it at all.

If an OS theme uses the same color for the input background as for graytext, that's a bug in that theme and should be fixed there.

Comment 4

9 years ago
I apologize, I misunderstood where the value of GrayText comes from.  However, I'm still not convinced it would be a theme bug at present.  To wit:

https://bugzilla.gnome.org/show_bug.cgi?id=440963 is the GNOME bug for adding hinting to GtkEntry.  As one can see there is debate on the utility of hinting.  Comment #2 points out the visual semantic issues with using the insensitive text color there (equivalent to GrayText).  

http://library.gnome.org/devel/hig-book/2.32/controls-sensitivity.html.en has the GNOME Human Interface Guidelines regarding sensitivity.  The indication there is that the use of insensitive elements is for when the user may not interact with a particular control.  The use of GrayText here and in placeholder would seem to contradict the guidelines there.  

Finally, bug 556145 discusses the use of opacity versus GrayText for placeholder text (what GNOME is calling hinting).  For consistency (even if the result is broken in both places), the resolution of this bug should follow that outcome.  

If hinting lands in GNOME, then GNOME or the theme should get the bug. Currently, the bugs belong to the applications that roll their own hinting using the insensitive color.

Updated

9 years ago
Duplicate of this bug: 604157
OS-->All
Bug 604157 is about Mac and was marked as a dupe of this.
OS: Linux → All

Comment 7

9 years ago
Bug 604157 was not just about Mac.  It was supposed to be for any platform that can run Firefox.

Updated

9 years ago
Duplicate of this bug: 613499

Updated

9 years ago
Summary: Hovered link target shown in the location bar isn't dark enough to read comfortably → Hovered link target shown in the location bar isn't dark enough to read

Comment 9

8 years ago
Belated closing as WFM seeing as the location bar hover link was scraped in favor of an easier to read box in the lower corner.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.