Link hover in location bar: The arrow needs better styling

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: info, Unassigned)

Tracking

({polish, ux-natural-mapping})

Trunk
x86_64
Linux
polish, ux-natural-mapping
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre

I'm getting used to the URLs of hovered links appearing in the location bar.
But in nightly Mozilla 64-bit builds on Kubuntu 10.04 (using I believe some compatibility Gnome theme) the arrow between the current URL and the new one looks bad.

Reproducible: Always

Steps to Reproduce:
1. Roll over a hyperlink
2. Watch the location bar
Actual Results:  
The arrow in the location bar:
* Has a weird gray bloom to its right that draws the eye
* Leaves space to its left
* Is bigger and appears darker than the hovered URL after it, so your eye is drawn to it rather than the new text.
* Has a pixel glitch in the top border.

Expected Results:  
a) Get rid of the gray bloom and pixel glitch
b) If the current URL is truncated, shift the arrow left to overlap the ellipsis.  That way it looks less like a standalone element
c) Lighten the arrow
d) Make the new URL text darker than the arrow (this is bug 597382).
e) Make the arrow more chrome-like, e.g. round the pixels, doorhangar style.
f) um....?

I'll attach a picture that addresses a,b,c.

I also agree with a bug/comment somewhere about lightening the current favicon/site info when the hovered URL appears.

The overall feel should be that the current locations retreats/is overlayed to show the new URL.  That's a bigger topic than these arrow glitches, good luck getting there!
(Reporter)

Comment 1

8 years ago
Created attachment 476584 [details]
screenshot showing glitches, and a possible fix

Comment 2

8 years ago
Confirming based on basic premise of this bug.

I've said this elsewhere, but I really would like this arrow to stand out more. I think it should be "hyperlink blue" or "go button green" on all OSes.
Blocks: 587908
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, ux-natural-mapping
Summary: [polish] the arrow before a hyperlink URL in the location bar looks bad → Link hover in location bar: The arrow needs better styling
Version: unspecified → Trunk

Comment 3

8 years ago
"Go button green" would be more appropriate in this case, and since authors usually change the colour of hyperlinks.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.