Closed Bug 5974 Opened 21 years ago Closed 20 years ago

View | Page source should display Japanese with META charset

Categories

(Core :: Internationalization, defect, P3, major)

All
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: teruko, Assigned: vidur)

References

Details

Attachments

(1 file)

Tested 5-5-6 Win32 build.

Now the menu View| Page source is enabled, but it does not display Japanese characters.
Target Milestone: M6
Status: NEW → ASSIGNED
Target Milestone: M6 → M8
The problem is we does not pass the charset information to the new window. We
should pass the default charset value as well as the current charset to the new
WebShell.Make it M8
Frank will probably be out on paternity leave during M8.  Moved to M9.
Blocks: 7228
Target Milestone: M9 → M10
move to M10
Target Milestone: M10 → M9
changr back to M9
Target Milestone: M9 → M10
Assignee: ftang → harishd
Status: ASSIGNED → NEW
Summary: View | Page source should display Japanese characters → View | Page source should display Japanese characters when the page have META charset
Target Milestone: M10 → M11
change the summary from "View | Page source should display Japanese characters"
to "View | Page source should display Japanese characters when the page have
META charset"
What happened is CViewSourceHTML didn't hanld META charset as CNavDTD does.
Reassign this to harishd. I will open a seperate bug for the case of default
charset and assign that one to myself.

harishd, can you make it for M11? Let me know your estimatation first . Thanks.
Status: NEW → ASSIGNED
Target Milestone: M11 → M10
This shouldn't take too long.  I'll try to get it in for M10.

Setting milestone to M10.
Added ftang to the CC list.
Assignee: harishd → ftang
Status: ASSIGNED → NEW
Reassingning bug to ftang@netscape.com.
Status: NEW → ASSIGNED
Target Milestone: M10 → M11
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Summary: View | Page source should display Japanese characters when the page have META charset → View | Page source should display Japanese with META charset
fixed and check in
Now we pass the parser command to webshell...
Status: RESOLVED → REOPENED
break by vidure since he change the line cmd to "view" in nsWebShell.cpp line
193x.

vidure, please back out that line (change "view" back to cmd to fix it.
Resolution: FIXED → ---
Assignee: ftang → vidur
Status: REOPENED → NEW
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Sorry, Frank. Restored Franks change that was lost during my merge and checkin
late last week.
I verified as fix in 9-23-08 Mac and Windows.  I cannot verify in Linux due to
the bug 14802.
Status: RESOLVED → VERIFIED
I verified this in 9-29 Linux build.
You need to log in before you can comment on or make changes to this bug.