Closed Bug 597681 Opened 9 years ago Closed 4 years ago

Improve switch from Tab Candy/Panorama expanded thumbnail to (empty) real content tab when a not-loaded tab is selected in Tab Candy/Panorama

Categories

(Firefox Graveyard :: Panorama, enhancement)

enhancement
Not set

Tracking

(blocking2.0 -)

RESOLVED WONTFIX
Future
Tracking Status
blocking2.0 --- -

People

(Reporter: NicolasWeb, Unassigned)

References

Details

(Whiteboard: [aza])

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; fr; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: 

Find a better transition from Tab Candy/Panorama expanded thumbnail to real content tab when a not-loaded tab is selected in Tab Candy/Panorama.

The problem, is that if a tab haven't been loaded, Tab Candy/Panorama transform-expand the thumbnail and then we have a transition to ... a blank and loading page.

We should at least find a better transition to a loading tab.

Not sure if that is a Tab Candy or Tabbed Browser Bug ?

Reproducible: Always
Maybe (yes, maybe ; and with all the debate in bug 544818, bug 578028, bug 597673, can't find the one for implementing the UpdateIcon/circular page loading progress pie), we should think again how we show loading progress in the browser...

Maybe a solution could be to add a progress meter on to of the thumbnail in tab Candy until the tab is enought loaded. Hide the progress meter and then expand to the real content of the tab.
Depends on: 544818, 578028, 597673
Blocks: 561149
Keywords: uiwanted
No longer blocks: 561149
Depends on: 561149, 595601
(In reply to comment #1)
> Maybe a solution could be to add a progress meter on to of the thumbnail in tab
> Candy until the tab is enought loaded. Hide the progress meter and then expand
> to the real content of the tab.

Read on top of the thumbnail.
Hiding the progress meter could be progressive too, for beauty ;-)
Summary: Find a better transition from Tab Candy/Panorama expanded thumbnail to real content tab when a not-loaded tab is selected in Tab Candy/Panorama → Find a better transition from Tab Candy/Panorama expanded thumbnail to (empty) real content tab when a not-loaded tab is selected in Tab Candy/Panorama
Summary: Find a better transition from Tab Candy/Panorama expanded thumbnail to (empty) real content tab when a not-loaded tab is selected in Tab Candy/Panorama → Improve switch from Tab Candy/Panorama expanded thumbnail to (empty) real content tab when a not-loaded tab is selected in Tab Candy/Panorama
Blocks: 597043
blocking2.0: --- → ?
I like how Safari handles this (showing a dimmed version of the full-size thumbnail until the page has loaded enough, then fading into it).

I don't think we're going to be able to get to this in time for FF4.0, however.
Assignee: nobody → aza
No longer blocks: 597043
Target Milestone: --- → Future
Status: UNCONFIRMED → NEW
blocking2.0: ? → -
Ever confirmed: true
Assignee: aza → nobody
Whiteboard: [aza]
Assignee: nobody → limi
Keywords: uiwanted
Assignee: limi → nobody
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.