Closed Bug 597728 Opened 11 years ago Closed 11 years ago

Firefox keep 100% CPU and would not kill Firefox process when I execute File > Exit

Categories

(Core :: Networking: Cookies, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 595925
mozilla2.0

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre ID:20100918041706

Firefox keep 100% CPU and would not kill own process when I execute File > Exit

The attached sample places.sqlite contains a folder which includes 21 bookmarks(twitter) in Bookmarks Toolbar.

Reproducible: Always

Steps to Reproduce:
1. Prepare Fresh profile and Import Sample places.sqlite  
2. Start Minefield with above profile
3. Open a Folder (Middle Click a "twitter" in Bookmarks Toolbar)
4. Wait complete loading of page
5. File > Exit
6. Repeat step2-5  more than 2 times

Actual Results:
 Firefox keep 100% CPU and would not kill Firefox process

Expected Results:
 Should kill firefox process immediately

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/c402a67ba0db
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre ID:20100729142730
Fails:
http://hg.mozilla.org/mozilla-central/rev/6d0d4c0c8890
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre ID:20100729143014
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c402a67ba0db&tochange=6d0d4c0c8890
Bug 572223 - too much cookies.sqlite io
blocking2.0: --- → ?
dwitte, looks like you?
This is going to be fixed by bug 595925.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595925
This was fixed on 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre ID:20101020042802.
Clearing blocking request.
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.