Ctrl+F should hide the findbar if the findbar is focused

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: Dominic, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre

Ctrl+F should hide the findbar if the findbar is focused

Reproducible: Always

Steps to Reproduce:
1. Hit ctrl+f
*findbar shows*
2. Find a term
3. Hit ctrl+f again
Actual Results:  
Nothing

Expected Results:  
Findbar should hide
(Reporter)

Updated

7 years ago
Blocks: 565552

Updated

7 years ago
Whiteboard: dupeme

Comment 1

7 years ago
One of the first things I noticed on FF4.

Comment 2

7 years ago
This is not behavior that we want.
Ctrl+F is Find, not Toggle Find.
Making it into Toggle Find will cause mode errors.
Pressing Ctrl+F actually does something while the find bar is focused: it selects all the text in the field, so that whatever is immediately typed will overwrite what used to be there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 747674
Duplicate of this bug: 762850

Comment 5

5 years ago
(In reply to Frank Yan (:fryn) from comment #2)
> This is not behavior that we want.
> Ctrl+F is Find, not Toggle Find.
> Making it into Toggle Find will cause mode errors.
> Pressing Ctrl+F actually does something while the find bar is focused: it
> selects all the text in the field, so that whatever is immediately typed
> will overwrite what used to be there.

Who is "we" here? I guess for Firefox "we" is all the user combined and I put forward my point.

Updated

4 years ago
Whiteboard: dupeme

Updated

4 years ago
Duplicate of this bug: 992782
You need to log in before you can comment on or make changes to this bug.