Sync : failed to connect to the server

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Ioana Chiorean, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
Build Identifier: Mozilla/5.0 (Android; Linux armv7l; en-US; rv:2.0b7pre)
Gecko/20090920 Firefox/4.0b7pre Fennec/2.0b1pre 
Device Motorola Droid 2.2 

Steps to reproduce:
1. Go to preferences -> Sync Section
2. Enter a valid account and details

Expected result:
- the connection to the server should be established 

Actual result:
- the connection is not made: Failed to connect to the server error appear in gray and the status disconnected

Note: using same account I was able to login from Android 2.1, Maemo and desktop today.
	

    Collapse All Comments
    E

Comment 1

7 years ago
For what its worth, This works for me on the nokia n900.  i am able to connect to sync with an existing account.

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b7pre) Gecko/20100920 Firefox/4.0b7pre Fennec/2.0b1pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20100920 Firefox/4.0b7pre Fennec/2.0b1pre

If you use a username not an email address with the old secretphrase, it will work on the Android.

If you use an email address with the new secret mixed phrase, it does not seem to work.

After talking to Tony, it appears that the android plugin needs to be updated.
(In reply to comment #2)
> Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20100920 Firefox/4.0b7pre
> Fennec/2.0b1pre
> 
> If you use a username not an email address with the old secretphrase, it will
> work on the Android.
> 
> If you use an email address with the new secret mixed phrase, it does not seem
> to work.
> 
> After talking to Tony, it appears that the android plugin needs to be updated.

This is a dupe of bug 597025
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597025
(Reporter)

Comment 4

7 years ago
Is not about an e-mail address as user name. Like I have already stated same account worked on N900 Maemo GTK, N900 Maemo QT and HTC Desire Android 2.1. It failed to connect on a Motorola Droid with Android 2.2

Account details:
- username : svioana
- password : Chiorean
- secret phrase: mergem la mare (it contains 2 spaces)

So is not the case of using an email address. Please set the appropriate status for this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

7 years ago
Can you open about:sync-log and see if there are any helpful errors after attempting to log in?
OS: Android → All

Comment 6

7 years ago
Ioana, is this still reproducing on the 09/21 nightly?  I thought you verbally said it was working.  if so, please revert status.  if not, list repro steps and logs.
(Reporter)

Comment 7

7 years ago
the bad behavior did not reproduce anymore. Now I can login without problems and no server error appears.

Comment 8

7 years ago
changing status based on comment 7
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.