Mozmill Update tests broken due to relocation of update dialog

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100921 Firefox/4.0b7pre

With the fixes on bug 306018 and bug 585475 we cannot open the update dialog anymore with Mozmill. Therefore we have to update the SoftwareUpdateAPI:

IF version >= 4.0b7
  IF mac
    Open via "Minefield | Check for Updates..."
  ELSE
    Open via about dialog
ELSE
  Open via "Help | Check for Updates..."

Given that path we will still be able to run update tests for older alpha and beta releases of Firefox 4.0. The old code can be dropped once we have Firefox 4.0 released.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 598340
(Assignee)

Comment 2

8 years ago
To be able to have update tests working with nightly builds we will have to check for 4.0b7pre instead of 4.0b7.
(Assignee)

Comment 3

8 years ago
Created attachment 477309 [details] [diff] [review]
Patch v1 (default)

Tested on all platforms with nightly builds for partial and fallback updates. Also tested older release builds to make sure the version condition works as expected.
Attachment #477309 - Flags: review?(anthony.s.hughes)
Attachment #477309 - Flags: review?(anthony.s.hughes) → review+
(Assignee)

Comment 4

8 years ago
Landed on default:
http://hg.mozilla.org/qa/mozmill-tests/rev/86b64b54daeb
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

8 years ago
Move of Mozmill Test related project bugs to newly created components. You can
filter out those emails by using "Mozmill-Tests-to-MozillaQA" as criteria.
Component: Mozmill Tests → Mozmill Tests
Product: Testing → Mozilla QA
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.