Closed Bug 598754 Opened 9 years ago Closed 9 years ago

[D3D9] Adobe reader plugin lets previously painted content from other tab show through

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bjacob, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Attached image glitch
Steps:
 1. Set gfx.direct2d.disabled = true (not necessary, but I thought you'd find
it intersting to know this happens not only with Direct2D)
 2. Restart firefox, go to mibbit.com in the first tab,
 3. open a new tab, go to:
  http://www.khronos.org/registry/gles/specs/2.0/es_full_spec_2.0.24.pdf
 Using the Adobe PDF Reader plugin.
 4. go back to mibbit tab and then back again to PDF tab.

Result: attached screenshot.

I have windows 7, UA string:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100921
Firefox/4.0b7pre

This seems to be independent of whether Direct2D is enabled.
Confirmed.

Note: i had to switch between the tabs several times to reproduce this.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/b57dda2ee56d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre ID:20100904212104
Fails:
http://hg.mozilla.org/mozilla-central/rev/fd13b6ce36bd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre ID:20100904234810
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b57dda2ee56d&tochange=fd13b6ce36bd
Awesome work Alice0775!

CC'ing Joe...

There are 2 changesets in this regression window. One of them is enabling D3D accel. Can someone check if the bug persists with D3D disabled? Set layers.accelerate-all=false and -none=true. (I'm not on Windows at the moment).

If the issue persists, one should look at the other of these 2 changesets.
*ahem* no sorry, both changesets are D3D specific...
Anyway, I set prefs as follows and confirmed that the problem does not happen.
layers.accelerate-all;false
layers.accelerate-none;true

http://hg.mozilla.org/mozilla-central/rev/eec9a82ad740
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre ID:20100923041416
ok, well that's interesting, you proved that the problem is with d3d acceleration!
I Force enabled D3D9 by user_pref("layers.accelerate-all", true); in user.js,
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7aaf30721c48&tochange=4b879b793eb6


BTW;
During loading of the PDF, whole contents area of pdf tab becomes the image of another tab when I switch tabs between PDF tab and onother tab.
And It happens till loading of the PDF is completed.

Is this behavior Bug? did already file a Bug?
Blocks: d3d9-layers
Summary: Adobe reader plugin lets previously painted content from other tab show through → [D3D9] Adobe reader plugin lets previously painted content from other tab show through
Version: unspecified → Trunk
(In reply to comment #7)
> I Force enabled D3D9 by user_pref("layers.accelerate-all", true); in user.js,
> Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7aaf30721c48&tochange=4b879b793eb6

Awesome! Since this range contains mostly commits by Roc and Matt, CC'ing them.

> 
> 
> BTW;
> During loading of the PDF, whole contents area of pdf tab becomes the image of
> another tab when I switch tabs between PDF tab and onother tab.
> And It happens till loading of the PDF is completed.
> 
> Is this behavior Bug? did already file a Bug?

I have no idea whether it's a bug, I'll let them answer that.
Duplicate of this bug: 606753
Experiencing same bug. 
Also happens with firefox 3.6.11though. Since I deal a lot with pdf online, I feel like this bug has always been part of firefox, as far as I remember. Would be nice if adressed though...
I can not reproduce the problem any more on latest m-c nightly,
Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre ID:20110125030335

Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=854b6fb7e04c&tochange=760cbafe478b


Graphics
  Adapter Description: VMware SVGA II
  Vendor ID: 15ad
  Device ID: 0405
  Adapter RAM: Unknown
  Adapter Drivers: vmx_fb
  Driver Version: 11.6.0.35
  Driver Date: 4-21-2010
  Direct2D Enabled: false
  DirectWrite Enabled: false (0.0.0.0)
  WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 24 2011 07:19:03)
  GPU Accelerated Windows: 1/1 Direct3D 9
> I can not reproduce the problem any more on latest m-c nightly,
Me too. I close it as "workforme"
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 593389
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.