Investigate putting (large-ish) content images in their own layers

RESOLVED DUPLICATE of bug 650988

Status

()

defect
RESOLVED DUPLICATE of bug 650988
9 years ago
7 years ago

People

(Reporter: cjones, Unassigned)

Tracking

unspecified
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec-)

Details

This would allow us to avoid scaling images in SW in content processes.  Instead, we would set scales on images' layers, then scale them with GL during compositing.  The potential benefit from this would be to save CPU cycles, use better interpolation with GL, and (possibly) reduce system memory usage.

There are many cases when this scheme would lose big time.  We'd need heuristics for when to do this.

This is strictly a losing proposition with SW compositing.
Um, don't know how that dependency snuck in.
No longer blocks: 570294
For JPEG images, we could also decode to YCbCr format (i.e. skip the final YCbCr-to-RGB conversion in the imglib decoder), and do the final YCbCr conversion using the GPU at draw time. That would save half the memory since JPEG subsamples Cb/Cr. We already have all the layer-side support for this.
Blocks: 598736
tracking-fennec: --- → ?
Duplicate of this bug: 650988
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650988
tracking-fennec: ? → -
You need to log in before you can comment on or make changes to this bug.