Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Mac universal build fails unifying architectures after IPC/OOPP landing

VERIFIED FIXED in seamonkey2.1b1

Status

SeaMonkey
Build Config
--
blocker
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: Robert Kaiser)

Tracking

({regression})

Trunk
seamonkey2.1b1
x86
Mac OS X
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1285209212.1285221502.27658.gz
OS X 10.5 comm-central-trunk build on 2010/09/22 19:33:32
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1285227000.1285234039.16040.gz
OS X 10.5 comm-central-trunk nightly on 2010/09/23 00:30:00
{
/builds/slave/comm-central-trunk-macosx-nightly/build/mozilla/build/macosx/universal/unify: copyIfIdenticalWhenSorted: files differ:
  objdir/ppc/mozilla/dist/seamonkey/SeaMonkey.app/Contents/MacOS/components/components.manifest,
  objdir/i386/mozilla/dist/seamonkey/SeaMonkey.app/Contents/MacOS/components/components.manifest
make[1]: *** [postflight_all] Error 1
}
(Reporter)

Updated

7 years ago
blocking-seamonkey2.1: --- → ?
(Reporter)

Updated

7 years ago
Summary: [MacOSX] "copyIfIdenticalWhenSorted: files differ ... components.manifest" after bug 545716 → [Opt MacOSX] "copyIfIdenticalWhenSorted: files differ ... components.manifest" after bug 545716
(Assignee)

Comment 1

7 years ago
I'm looking into this, no need to mark anything as a release blocker that makes builds fail anyhow.
Assignee: nobody → kairo
blocking-seamonkey2.1: ? → ---
Keywords: regression
Summary: [Opt MacOSX] "copyIfIdenticalWhenSorted: files differ ... components.manifest" after bug 545716 → Mac universal build fails unifying components.manifest after IPC/OOPP landing
(Assignee)

Comment 2

7 years ago
The diff is this:

-# messageWakeupService.manifest
-component {f9798742-4f7b-4188-86ba-48b116412b29} messageWakeupService.js
-contract @mozilla.org/content/messagewakeupservice;1 {f9798742-4f7b-4188-86ba-48b116412b29}
-category profile-after-change messageWakeupService @mozilla.org/content/messagewakeupservice;1
-
-

As PPC doesn't have IPC but x86 does, we need to see that both include this, no matter what, and just let it fail at loading time for PPC.
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Actually, Firefox doesn't have this in its packaging and therefore doesn't include it for anyone yet, we might actually want to do the same.
(Assignee)

Comment 4

7 years ago
Created attachment 477912 [details] [diff] [review]
exclude messageWakeupService from packaging again

This should do it. I'm leaving this in as a commented block in the package manifest, as it will appear in package-compare, but this is only used for communication to content processes, and we don't have those yet anyhow, so we can just leave it out in packaging.
It doesn't harm not to remove it, as it will be removed from the manifest anyhow, and we won't support downgrading to non-IPC builds anyhow, so I'm removing it from removed-files completely.
Attachment #477912 - Flags: review?(bugspam.Callek)

Updated

7 years ago
Attachment #477912 - Flags: review?(bugspam.Callek) → review+
(Reporter)

Updated

7 years ago
Blocks: 594430
(Assignee)

Comment 5

7 years ago
Pushed as http://hg.mozilla.org/comm-central/rev/d73e09120944 - this should be fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: --- → seamonkey2.1b1
(Reporter)

Comment 6

7 years ago
Hum, new error:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1285251672.1285252766.5926.gz
OS X 10.5 comm-central-trunk build on 2010/09/23 07:21:12
{
/builds/slave/comm-central-trunk-macosx/build/mozilla/build/macosx/universal/unify: copyIfIdentical: files differ:
  objdir/ppc/mozilla/dist/seamonkey/SeaMonkey.app/Contents/MacOS/removed-files,
  objdir/i386/mozilla/dist/seamonkey/SeaMonkey.app/Contents/MacOS/removed-files
make[1]: *** [postflight_all] Error 1
}
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

7 years ago
Yes, removed-files isn't IPC-free, need to fix that. It even removes a file we never shipped. Go figure. ;-)
(Assignee)

Comment 8

7 years ago
Created attachment 477934 [details] [diff] [review]
Remove remnant from removed-files

This one fixes the diff of removed-files. We never shipped mozilla-runtime anyhow, and we don't support downgrading to non-IPC packages on trunk anyhow.
Attachment #477934 - Flags: review?(bugspam.Callek)

Updated

7 years ago
Attachment #477934 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 9

7 years ago
Pushed the second patch as http://hg.mozilla.org/comm-central/rev/6644f7111552 - I hope it's really fixed now.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

7 years ago
reopening again, now it errors out on having plugin-container.app only on i386 - and in the end, we need it to just activate MOZ_IPC.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

7 years ago
Created attachment 477956 [details] [diff] [review]
Make PPC activate MOZ_IPC (just like mozilla-central does)

It looks like we just don't have to force MOZ_IPC off on PPC. This matches the mozilla-central configure.in.
Attachment #477956 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

7 years ago
Summary: Mac universal build fails unifying components.manifest after IPC/OOPP landing → Mac universal build fails unifying architectures after IPC/OOPP landing

Updated

7 years ago
Attachment #477956 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 12

7 years ago
http://hg.mozilla.org/comm-central/rev/69fa25b390db - and I hope that really closes this once and for all now!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

7 years ago
V.Fixed, as we now (after some more reds) have green builds.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

6 years ago
Depends on: 563747
You need to log in before you can comment on or make changes to this bug.