Closed Bug 598939 Opened 9 years ago Closed 9 years ago

The right area of electric flower webgl demo display becomes white in a few seconds with Intel graphic card

Categories

(Core :: Canvas: WebGL, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 603367

People

(Reporter: scoobidiver, Unassigned)

References

()

Details

(Whiteboard: webglsamples)

Attachments

(1 file)

Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

Whatever the shader_validator value, the right area of electric flower webgl demo display becomes more and more bright, until reaching white color.
To have a right display, a clicking on "radial blur" is necessary.

Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID: 8086
Device ID: 2a42
Adapter RAM: Unknown
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 8.15.10.2202
Driver Date: 8-25-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 1/1 Direct3D 9
Is it affected if you disable D3D layers acceleration?  (layers.accelerate-xxx)

This bug sounds a lot like a compositing issue where we draw a transparent layer again and again, accumulating opaqueness.

All I can say is that here (linux) I can't reproduce.
> Is it affected if you disable D3D layers acceleration?  (layers.accelerate-xxx)
No, I set layers.accelerate-all to false and layers.accelerate-none to true, I restarted FF, the result was the same
The same also if I disabled D2D.

I tried in Minefield 64-bit, the same except that the display becomes right after 10 seconds without doing anything.
OK. At this point, a driver issue sounds like the most likely cause, see bug 598940 comment 2.
Summary: The right area of electric flower webgl demo display becomes white in a few seconds → The right area of electric flower webgl demo display becomes white in a few seconds with Intel graphic card
Now, with shader validator set to true, I don't have this issue (ANGLE r445), but I have new rendering issues (I will file a new bug for that).
With shader validator set to false, I still have the issue, because it is probably a driver bug.
Whiteboard: webglsamples
-> ANGLE
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603367
You need to log in before you can comment on or make changes to this bug.