[ANGLE] Field WebGL demo display, shader validator ON: no animated object, shader validator OFF: bad object rendering with Intel OpenGL renderer

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: webglsamples, URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 477919 [details]
field webgl demo screenshot with shader validator ON

Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

* If shader_validator is set to true (default value):
The field webgl demo display is composed of a black rectangle on the left and a grey rectangle on the right. The rectangle size can be different, each time.

* If shader_validator is set to false :
The left rectangle contains animated sharp grass in front of a black background.
The right rectangle contains frozen fuzzy grass in front of a blue background.
The rectangle size can be different, each time.


Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID: 8086
Device ID: 2a42
Adapter RAM: Unknown
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 8.15.10.2202
Driver Date: 8-25-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 1/1 Direct3D 9
(Reporter)

Comment 1

8 years ago
Created attachment 477920 [details]
field webgl demo screenshot with shader validator OFF
First of all it's important to say that the ANGLE shader validator is not only validating, it's also translating from GLSL ES to GLSL.

The glich with the ANGLE translator ON can be either a bug in ANGLE, or a bug in your graphics card's OpenGL driver.

The glich with the ANGLE translator OFF can be either a GLSL ES shader that won't run on GLSL (does that exist? Do we need to do something to enable certain reserved gl_Xxx variables), or a bug in your graphics card's OpenGL driver.
The reason why I insist on your graphics card OpenGL driver is that you have a Intel card on Windows. This is known to be problematic. Can you go to 

http://spidergl.org/example.php?id=8

and tell me if you see the terrain correctly? We know that the only way to correctly support your hardware on windows is using Direct3D via ANGLE, but we also know that ANGLE has serious bugs. However, if you see stuff working better in Chromium, that would mean that ANGLE issues have been solved.
(Reporter)

Comment 3

8 years ago
Spider webgl demo results :
* shader_validator set to true :
  + blue screen
  + moving FF hangs the system
* shader_validator set to false :
  + terrain is greenish on the left side and redish on the right side
  + Key response is very slow
  + moving FF hangs the system
* chromium 7.0.532.0 (60288) :
  + blue screen
  + [PROGRAM LOG] FAIL:error X3004: undeclared identifier 'gl_texture2D
(In reply to comment #3)
> Spider webgl demo results :
> * shader_validator set to true :
>   + blue screen
>   + moving FF hangs the system

ok, from what you say below, that can only be explained by a ANGLE shader translator bug.

> * shader_validator set to false :
>   + terrain is greenish on the left side and redish on the right side
>   + Key response is very slow
>   + moving FF hangs the system

ok, driver issue. We've had another Intel/Windows user reporting the same bad rendering that you describe.

> * chromium 7.0.532.0 (60288) :
>   + blue screen
>   + [PROGRAM LOG] FAIL:error X3004: undeclared identifier 'gl_texture2D

thanks, great to know, that means that ANGLE is still broken (since they are using not only the ANGLE shader translator but also the ANGLE GLES2-on-top-of-D3D stuff, and Intel is supposed to at least have decent D3D drivers, that can only be explained by ANGLE bugs).

In conclusion, life will be miserable for you until ANGLE improves.

You could file bug reports against ANGLE and/or Chromium, pointing out to the bad rendering in Chromium will be more effective as the Chromium and ANGLE teams overlap a lot.
(Reporter)

Updated

8 years ago
Summary: Wrong display of field webgl demo → [WebGL] [ANGLE] [Intel card] Field and spider demos display, shader validator ON: no animated object, shader validator OFF: bad object rendering
blocking2.0: --- → ?
blocking2.0: ? → -
(Reporter)

Comment 5

8 years ago
> * If shader_validator is set to true (default value):
> The field webgl demo display is composed of a black rectangle on the left and 
> a grey rectangle on the right. The rectangle size can be different, each time.
Still applicable with ANGLE r445.
It works in Chrome dev 7.0.544.0 

>> Spider webgl demo results :
>> * shader_validator set to true :
>>   + blue screen
>>   + moving FF hangs the system
> ok, from what you say below, that can only be explained by a ANGLE shader
> translator bug.
Still applicable with ANGLE r445, either in Minefield or Chrome dev 7.0.544.0
(Reporter)

Updated

8 years ago
Whiteboard: webglsamples
-> ANGLE d3d/intel
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603367
(Reporter)

Comment 7

8 years ago
Build ID: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101213 Firefox/4.0b8pre

It is not fixed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

8 years ago
Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID: 8086
Device ID: 2a42
Adapter RAM: Unknown
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 8.15.10.2226
Driver Date: 10-15-2010
Direct2D Enabled: true
DirectWrite Enabled: true
WebGL Renderer: Intel -- Mobile Intel(R) 4 Series Express Chipset Family -- 2.1.0 - Build 8.15.10.2226
GPU Accelerated Windows: 1/1 Direct3D 10
(Reporter)

Comment 9

8 years ago
With DirectX runtime renderer:
WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 10 2011 19:54:16)
Field WebGL demo works whatever shader_validator value.
Spider GL demo is blue whatever shader_validator value. Still fails.
Summary: [WebGL] [ANGLE] [Intel card] Field and spider demos display, shader validator ON: no animated object, shader validator OFF: bad object rendering → [WebGL] [ANGLE] [Intel card] Field and spider demos display, shader validator ON: no animated object, shader validator OFF: bad object rendering with OpenGL renderer
(Reporter)

Comment 10

8 years ago
I filed bug 625308 for the specific issue with SpiderGL.
Summary: [WebGL] [ANGLE] [Intel card] Field and spider demos display, shader validator ON: no animated object, shader validator OFF: bad object rendering with OpenGL renderer → [ANGLE] Field WebGL demo display, shader validator ON: no animated object, shader validator OFF: bad object rendering with Intel OpenGL renderer
(Reporter)

Comment 11

8 years ago
With today's build, there is no need to install DirectX runtime to use ANGLE:
WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Depends on: 629538
Resolution: --- → WORKSFORME
(Reporter)

Updated

8 years ago
Depends on: 625118
You need to log in before you can comment on or make changes to this bug.