Open Bug 599173 Opened 11 years ago Updated 5 years ago

[autoconfig] Account Creation should work when offline

Categories

(Thunderbird :: Account Manager, defect)

x86
All
defect
Not set
minor

Tracking

(thunderbird7-)

Tracking Status
thunderbird7 - ---

People

(Reporter: rolandtanglao, Unassigned)

Details

(Whiteboard: [autoconfig])

Steps to Reproduce:
1. Go Offline (i.e. turn off Wifi or unplug ethernet)
2. File->New->Mail Account ...
3. Enter Name, Email, Password and click Continue
4. You will receive the following exception:
"
[Exception... "Component returned failure code: 0x804b0010 (NS_ERROR_OFFLINE) [nsISocketTransportService.createTransport]"  nsresult: "0x804b0010 (NS_ERROR_OFFLINE)"  location: "JS frame :: chrome://messenger/content/accountcreation/guessConfig.js :: SocketUtil :: line 1071"  data: no]"
and you won't be able to create a Thunderbird email account manually
blocking-thunderbird3.2: --- → ?
Flags: blocking-thunderbird-next?
Can we dup your bug to bug 583602?
oops yes this is a duplicate, i missed bug 583602, my apologies, marking as duplicate
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583602
blocking-thunderbird3.2: ? → ---
Flags: blocking-thunderbird-next?
No longer depends on: 549045
REOPENing, because this bug is better stated.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Account Wizard doesn't work when offline for both manual and automatic mode → Account Wizard should work when offline for both manual and automatic mode
Severity: major → normal
Summary: Account Wizard should work when offline for both manual and automatic mode → [autoconfig] Account Creation should work when offline
Whiteboard: [autoconfig]
Some fix has been made in bug 583602, but that fix only works when the necko offline detection works, and even then is suboptimal. This bug shall be able to fix it better, which should be:

1. When we make a network connection to contact the ISPDB *, and there is no Internet connection, we will get back a certain error code. We actually do pass that back to emailWizard.js already. All we need to do is catch that specific error situation.
2. Show a warning "
It appears that you are not offline, i.e. not connected to the Internet, because we can't reach the configuration server. In order to get the best configuration and be able to verify it, please go online before setting up an account. If for some reason that is impossible, you can manually enter the configuration and finish by clicking "Advanced config", but that is not recommended.

Please go online.
[I cannot go online] [I will connect to Internet]
"
3. If the user says he can't go online, to straight to manual mode (as if configs failed) and allow to skip the "Re-Test", i.e. enable Advanced Config button after the user entered a syntactically valid hostname. I.e. the only change we need to do is to not force a "Re-Test" before enabling the "Advanced Config" button.

* Do not check at request do the ISP server, because that may well not exist and give similar errors. Error code from fetchhttp for "cannot reach DNS" and "cannot reach server" is -2, see
http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountcreation/fetchhttp.js#77 and #200

That should fix it. We need to undo the patch in bug 583602, too.
Status: REOPENED → NEW
Whilst we still want this, we're not going to actively drive it in at the moment.
Severity: normal → minor
You need to log in before you can comment on or make changes to this bug.