Default mail client check setting is ignored

RESOLVED DUPLICATE of bug 476426

Status

RESOLVED DUPLICATE of bug 476426
8 years ago
6 years ago

People

(Reporter: mcfly09, Unassigned)

Tracking

x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [STR comment 10])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

Preferences > Advanced > General > Always check to see if Thunderbird is the default mail client on startup is unchecked but TB ignores this setting and displays a dialog box on every startup asking if TB should be the default mail client.

Reproducible: Always

Steps to Reproduce:
1. Disable "Always check to see if Thunderbird is the default mail client on startup"
2. Restart Thunderbird
3. 
Actual Results:  
Dialog box is displayed

Expected Results:  
No dialog box should be displayed
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
does startin Tb in -safe-mode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode) helps ?
(Reporter)

Comment 2

8 years ago
Starting in safe mode does not keep this from happening. It happens when TB is launched and it also happens if I open a folder in a new window (ex. control+click on INBOX and select Open from the contextual menu).
What is the value of HKEY_LOCAL_MACHINE\Software\Clients\Mail on your machine ?
Component: General → OS Integration
QA Contact: general → os-integration
(Reporter)

Comment 4

8 years ago
This is OS X
(In reply to comment #3)
> What is the value of HKEY_LOCAL_MACHINE\Software\Clients\Mail on your machine ?

oups wrong bug I pasted that on.

Does this also happens on a fresh profile ?
(Reporter)

Comment 6

8 years ago
Yes
Is ThunderBird the default mail client ?
(Reporter)

Comment 8

8 years ago
No
Ok I've set mail.app as my default client. Unchecked the check at startup and I wasn't prompted , so I cannot reproduce with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.11) Gecko/20101013 Thunderbird/3.1.5.

Some thing is playing tricks. What's the default mail client ?
(Reporter)

Comment 10

8 years ago
I've done some more testing and this is what I've determined...
1) Create new profile
2) Start TB using new profile
3) Mail Account Setup window is displayed
4) Since we're just testing, Cancel out of that window
5) 'Use Thunderbird as the default client' panel is displayed
6) **Here's the catch...  Click Cancel
7) Go to Preferences
8) Deselect 'Always check to see if Thunderbird is the default mail client on startup' (should already be deselected)
9) Quit/relaunch TB
10) 'Use Thunderbird as the default client' panel is still displayed despite the preference setting that instructs the program not to display it.

Apparently until you click OK from the 'Use Thunderbird as the default client' panel the app will display the panel no matter what. In essence you're forcing the user to click OK in that panel. Until the OK button is clicked then the application preference setting is irrelevant. It seems to me that app pref setting should take precedence.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [STR comment 10]

Comment 11

6 years ago
If step 6 is the problem here then see bug 476426.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476426
You need to log in before you can comment on or make changes to this bug.