Unresponsive script error in Sync.js during initial sync in Fennec

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: mconnor)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec-)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Running a current opt build of Fennec on Android, I got two "Unresponsive script" dialogs for Sync.js, during the initial sync after connecting to my sync account.  mfinkle reported the seeing the same thing on a recent Fennec build.

Fennec sets dom.max_chrome_script_run_time to 30 seconds - we could increase this if necessary, but we should figure out the cause first.
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
I also see timeouts in Preferences.js and not just during the initial sync

Updated

7 years ago
tracking-fennec: ? → 2.0b2+

Updated

7 years ago
Component: General → Firefox Sync: Backend
Product: Fennec → Mozilla Services
QA Contact: general → sync-backend
Version: Trunk → unspecified
I'd say that *where* the timeouts occur is rather arbitrary, but they would definitely be more likely during an initial sync since there's just a lot more going on there.

I don't know how a DOM script's run time is evaluated to be matched against 'dom.max_chrome_script_run_time' and how this evaluation copes with our funky Sync.js module (whose showing up in this bug is rather accidental I think).
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
blocking2.0: ? → final+
Doug tells me there's two bugs that will fix this issue. Which ones are they?

Comment 5

7 years ago
two related bugs (not sure of the bug numbers):

1) logging needs to be disabled for mobile
2) get crypto off of the main thread
Duplicate of this bug: 601647
(In reply to comment #5)
> 1) logging needs to be disabled for mobile

Bug 599928

> 2) get crypto off of the main thread

Bug 570619

Updated

7 years ago
Assignee: nobody → doug.turner

Comment 8

7 years ago
This is really a meta bug.  I marked Bug 570619 as blocking b2.
Assignee: doug.turner → mconnor
tracking-fennec: 2.0b2+ → 2.0-
Duplicate of this bug: 606146
Can we close this bug now?
Better question, is anyone still seeing this?
(Assignee)

Comment 12

7 years ago
No reports in a long while, resolving WFM.  Other bugs will help with related stuff, but I think this specific case exists now.
Status: NEW → RESOLVED
blocking2.0: final+ → ---
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.