Closed Bug 599225 Opened 10 years ago Closed 10 years ago

[Add-ons Bar] Spacer/Separator widgets aligned to top with no height

Categories

(Firefox :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: sparky, Unassigned)

References

Details

(Whiteboard: [addon bar])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

Spacer/Separator widgets, added to the Add-ons Bar, have no height and are aligned to top of the toolbar. This makes it exceedingly hard to remove them.

Reproducible: Always
Blocks: 574688
Version: unspecified → Trunk
Blocking on this for now. We should display these correctly.
Status: UNCONFIRMED → NEW
blocking2.0: --- → final+
Ever confirmed: true
Whiteboard: [needs css help]
As a side note, this is caused by the align="right" attribute. I've hacked around this in my Status-4-Evar extension.
https://addons.mozilla.org/firefox/addon/235283/

Basically:

* Remove the "align" attribute (well, set it to "stretch")

* Add some CSS

#status-bar
{
	margin: 0px !important;
	-moz-box-pack: end;
	-moz-box-ordinal-group: 5000;
}

* Add some JS

gNavToolbox.addEventListener("beforecustomization", function()
{
	let statusbar = document.getElementById("status-bar");
	if(statusbar)
	{
		statusbar.style.display = "none";
	}
}, false);

gNavToolbox.addEventListener("aftercustomization", function()
{
	let addon_bar = document.getElementById("addon-bar");
	let statusbar = document.getElementById("status-bar");
	if(statusbar)
	{
		// Set the flex approriately
		let flex = 1;
		let addon_bar_children = addon_bar.children;
		for(let i = 0; i < addon_bar_children.length; i++)
		{
			let child = addon_bar_children[i];
			if(child.id != "status-bar" && child.flex)
			{
				flex = 0;
				break;
			}
		}

		statusbar.flex = flex;
		statusbar.style.display = "";
	}
}, false);


Yes, it's a bit of a hack, and illustrates Bug 602971. But when Bug 598929 is fixed, this would be mostly unnecessary.
Whiteboard: [needs css help] → [needs css help][addon bar]
Bug 616014 removes align="right".
Depends on: 616014
Whiteboard: [needs css help][addon bar] → [addon bar]
Marking as fixed (match Bug 610975 since it's a dupe) as Bug 616014 solves the problem.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.