Not asking for a new password if wrong on some servers

VERIFIED DUPLICATE of bug 61171

Status

P3
normal
VERIFIED DUPLICATE of bug 61171
18 years ago
10 years ago

People

(Reporter: bugzilla77, Assigned: naving)

Tracking

({testcase})

Trunk
x86
Other
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This appens when I'm polling my mail on pop3.nordnet.fr (POP server)
This server answers: +ERR Huh ???
when you enter a wrong password.

Mail&news reports this as a single error and still think the password is ok,
so I can't change ths pwd and must reload.

Comment 1

18 years ago
reassigning jefft's bugs to naving
Assignee: jefft → naving

Comment 2

18 years ago
Reporter is this still a problem in the latest nightlies?

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
From Reporter:
> Still a problem on Build 2000121820

Marking NEW as per comments. Reporter can you give us a test login there so we
can try it out as well?

Comment 4

18 years ago
*** Bug 59942 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
More Notes from reporter:

I can't give you a passwd, but you can try my login : fcartegnie
so you can try on pop3.nordnet.fr 110
USER fcartegnie
PASS whateveryouwant


It will reply "Err-Huh?"
instead of Err-Authorization failed
And mozilla will not manage to ask for the right passwd

Comment 6

18 years ago
Adding testcase keyword
Keywords: testcase

Comment 7

18 years ago
I have a few POP account, 2 of them (which is using qmail) has the same problem
as this bug described.  Other accounts (unknown mail server) are working
correctly.  Strangely the MailNews from Netscape 6 doesn't have this problem
even for those 2 accounts.  Both Mozilla 0.6 & 0.7 suffer from this.

Comment 8

18 years ago
Confirming it with 2001012008 build on WINNT , when a wrong pswd is entered , a 
dialog comesup saying "unable to send password information to the server, 
contact your administrator or try again later". This dialog keeps coming when 
I tried to get messages, giving no way to specify correct password during this 
browser session.  Actually Alert message is misleading, unless it has sent the 
information to the server how can it checks whther paswd is correct or wrong. 
(May be this is possible by cookies)
(Reporter)

Comment 9

18 years ago
Tested on build 2001032319.
Seems Fixed, new popup asking for new password and displaying error msg
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
thanks for testing. verifying based on the previous comments 
Status: RESOLVED → VERIFIED
(Assignee)

Comment 11

18 years ago
FYI: This was fixed because I checked in fix for #61171. Reopening to mark it
as verified duplicate. 
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

18 years ago

*** This bug has been marked as a duplicate of 61171 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 13

18 years ago
vrfy
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.