"Assertion failure: obj->isExtensible(),"

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: gkw, Assigned: Waldo)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
aa = eval
function bb() {
    this.eval = aa
}
var f = (function () {
    (Object.seal)(this)
    l
})
try {
    f()
} catch (r) {}
bb()
try {
    f()
} catch (r) {
    bb()
}

asserts js debug shell on TM changeset 1c913526c597 without -m nor -j at Assertion failure: obj->isExtensible(),
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Updated

8 years ago
blocking2.0: ? → betaN+
(Reporter)

Comment 1

8 years ago
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   54278:441f83a81fb8
user:        Jim Blandy
date:        Tue Sep 21 11:35:30 2010 -0700
summary:     Bug 492845: Implement Object.isSealed, Object.seal. a=jwalden, r=brendan
Blocks: 492845
(Assignee)

Updated

8 years ago
Assignee: general → jwalden+bmo
OS: Linux → All
Hardware: x86 → All
(Assignee)

Comment 2

8 years ago
js> Object.preventExtensions(Object.preventExtensions({}))
Assertion failure: isExtensible(), at ../jsobjinlines.h:77
Aborted (core dumped)

I could have sworn I had an is-extensible early exit in my patches, doesn't seem so on a second look.  :-(  Easy to fix, just need to get to it amongst all other fixes.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 599459
(Assignee)

Comment 4

8 years ago
Created attachment 490283 [details] [diff] [review]
Patch and test

I took the opportunity to convert an unadorned boolean argument into a self-describing enum argument, but beyond that this is simple enough.
Attachment #490283 - Flags: review?(jimb)
Comment on attachment 490283 [details] [diff] [review]
Patch and test

Pretty... r=me fwiw, if you want to get it into tm this weekend.

/be
Attachment #490283 - Flags: review+
(Assignee)

Comment 6

8 years ago
"want" probably overstates my desire...but I have the time, so why not?  :-)

http://hg.mozilla.org/tracemonkey/rev/f12a5024ea45
Status: NEW → ASSIGNED
Whiteboard: fixed-in-tracemonkey

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/f12a5024ea45
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Attachment #490283 - Flags: review?(jimb)
Automatically extracted testcase for this bug was committed:

https://hg.mozilla.org/mozilla-central/rev/efaf8960a929
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.