Last Comment Bug 600241 - Major part of Minefield's files has a modification date set to 2010-01-01
: Major part of Minefield's files has a modification date set to 2010-01-01
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 All
: -- normal (vote)
: ---
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on:
Blocks: 592369 684957
  Show dependency treegraph
 
Reported: 2010-09-28 10:14 PDT by Scoobidiver (away)
Modified: 2011-09-06 12:50 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Use zip stripping script (10.89 KB, patch)
2011-04-11 17:14 PDT, Michael Wu [:mwu]
taras.mozilla: review-
Details | Diff | Splinter Review
Strip zips during optimization (4.25 KB, patch)
2011-04-11 18:04 PDT, Michael Wu [:mwu]
no flags Details | Diff | Splinter Review
Strip zips during optimization, v2 (5.52 KB, patch)
2011-04-11 18:33 PDT, Michael Wu [:mwu]
no flags Details | Diff | Splinter Review
Strip zips during optimization, v3 (5.70 KB, patch)
2011-05-03 10:52 PDT, Michael Wu [:mwu]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Scoobidiver (away) 2010-09-28 10:14:29 PDT
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100928 Firefox/4.0b7pre

Even with a recent creation date, the modification date of the major part of installed files is 2010/01/01 except 2 that have the modification date of the build:
chrome.manifest
omni.jar
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2010-09-28 10:17:33 PDT
Not caused by the installer...  this was caused by bug 592369. Moving to the component that causes this
Comment 2 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-10-01 11:54:11 PDT
mwu, we should only be setting the mod-date for files *in* the omnijar, right?
Comment 3 Michael Wu [:mwu] 2010-10-01 11:57:58 PDT
We probably could. Does something depend on this behavior?
Comment 4 Michael Wu [:mwu] 2010-10-06 13:18:54 PDT
A bit busy right now - not planning to work on this bug soon unless this causes problems beyond incorrect modified times.
Comment 5 Scoobidiver (away) 2011-02-10 09:34:04 PST
It is not yet fixed.
Comment 6 Scoobidiver (away) 2011-03-11 11:11:54 PST
Not fixed in 4.0 RC1.
Comment 7 Michael Wu [:mwu] 2011-04-11 17:14:17 PDT
Created attachment 525224 [details] [diff] [review]
Use zip stripping script
Comment 8 Michael Wu [:mwu] 2011-04-11 17:15:29 PDT
Comment on attachment 525224 [details] [diff] [review]
Use zip stripping script

Hm actually I think ted wants this more.
Comment 9 Michael Wu [:mwu] 2011-04-11 18:04:54 PDT
Created attachment 525249 [details] [diff] [review]
Strip zips during optimization
Comment 10 Michael Wu [:mwu] 2011-04-11 18:33:45 PDT
Created attachment 525261 [details] [diff] [review]
Strip zips during optimization, v2

Let's remove directory entries while we're at it.
Comment 11 Michael Wu [:mwu] 2011-05-03 10:52:01 PDT
Created attachment 529752 [details] [diff] [review]
Strip zips during optimization, v3

Need to also decrement dirend.cdir_entries when skipping directories.
Comment 12 (dormant account) 2011-05-23 13:09:24 PDT
Comment on attachment 529752 [details] [diff] [review]
Strip zips during optimization, v3

This file really needs more comments on what it does.
Comment 13 Michael Wu [:mwu] 2011-05-23 17:31:46 PDT
Two comments added.

http://hg.mozilla.org/mozilla-central/rev/1106d349833d

Note You need to log in before you can comment on or make changes to this bug.