Tab characters inserted into a textarea (or similar addon UI element) convert mostly to spaces

RESOLVED DUPLICATE of bug 577240

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 577240
8 years ago
8 years ago

People

(Reporter: flying sheep, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

when i paste a tab character (\t) into a textarea or something similar (like for example the “Stylish” style editor), they are converted into 4 spaces.

The rules behind this behavior are completely incomprehensible. The only reliable way to insert a tab is in an otherwise completely empty line.

The behavior is exactly the same if you use the “tabinta” extension (which allows you to type tabs with the tab key)

Reproducible: Sometimes

Steps to Reproduce:
1. copy a tab character from another application/from a webpage source
2. paste it in a _nonempty_ line
Actual Results:  
4 spaces pasted (except you are extremely lucky, then try again some times. if you still can’t reproduce this the about 4th time, i guess it’s a “works for you”)

Expected Results:  
a tab pasted. if i want spaces, i hit the biggest key on my keyboard.

No workaround, because it doesn’t matter if you paste or type the tab.

even if you paste multiple tabs, _most_ get converted. it’s really annoying.
You can see this bug fixed in the latest nightly from http://nightly.mozilla.org, or in beta 7 when it becomes available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 577240
You need to log in before you can comment on or make changes to this bug.