[regression] Escape key goes back in history when Form Helper is opened

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: vingtetun, Assigned: vingtetun)

Tracking

Details

Attachments

(1 attachment)

Created attachment 479271 [details] [diff] [review]
Patch

Form Helper is not a popup anymore (and so will be Find Helper in a few) and because of this if VK_ESCAPE is called we're going back in history instead of dismissing the helper.

Steps to reproduce:
 * launch fennec
 * go to google.fr
 * click on the google's textbox
 * hit the back arrow of your Android device hardware keyboard or hit ESC on desktop

Actual results:
 * fennec goes one page back into history and dismiss the form helper

Expected results:
 * fennec dismiss the form helper
Attachment #479271 - Flags: review?(mark.finkle)
Comment on attachment 479271 [details] [diff] [review]
Patch

Man, the handleEscape method is ever growing...
Attachment #479271 - Flags: review?(mark.finkle) → review+
tracking-fennec: --- → 2.0b2+
Whiteboard: [fennec-checkin-postb1]
(In reply to comment #1)
> Comment on attachment 479271 [details] [diff] [review]
> Patch
> 
> Man, the handleEscape method is ever growing...

yeah, this is moslty because the way we handle popups, dialogs, panels, ... sucks. At some point (after 2.0) we need to do some code cleanup and find a new way of doing it :(
Assignee: nobody → 21
pushed:
http://hg.mozilla.org/mobile-browser/rev/d4a5faa2a8eb
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fennec-checkin-postb1]
Form Helper feature is not available anymore on the latest Nightly build.

--
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110912
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.