trunk does not build with --enable-system-cairo

RESOLVED DUPLICATE of bug 595805

Status

()

RESOLVED DUPLICATE of bug 595805
8 years ago
8 years ago

People

(Reporter: arno, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Hi,
I'm trying to compile xulrunner with this line in .mozconfig:
ac_add_options --enable-system-cairo
but compilation fails with following error:

c++ -o gfxASurface.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /home/arno/mozilla/config/gcc_hidden.h -DIMPL_THEBES -DWOFF_MOZILLA_CLIENT -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -DEXCLUDE_SKIA_DEPENDENCIES -DCHROMIUM_MOZILLA_BUILD -DOS_LINUX=1 -DOS_POSIX=1 -I/home/arno/mozilla/ipc/chromium/src -I/home/arno/mozilla/ipc/glue -I../../ipc/ipdl/_ipdlheaders  -I/home/arno/mozilla/gfx/thebes -I. -I../../dist/include -I../../dist/include/nsprpub  -I/home/arno/mozilla/obj-x86_64-unknown-linux-gnu/xulrunner/dist/include/nspr -I/home/arno/mozilla/obj-x86_64-unknown-linux-gnu/xulrunner/dist/include/nss       -fPIC -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -fno-strict-aliasing -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer  -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-unix-print-2.0   -pthread -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2     -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/gfxASurface.pp /home/arno/mozilla/gfx/thebes/gfxASurface.cpp
/home/arno/mozilla/gfx/thebes/gfxASurface.cpp:492: error: ‘CAIRO_SURFACE_TYPE_SKIA’ was not declared in this scope
make[5]: *** [gfxASurface.o] Erreur 1
Component: Build Config → Graphics
QA Contact: build-config → thebes
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595805
You need to log in before you can comment on or make changes to this bug.