Update required cairo version to 1.10

RESOLVED FIXED in mozilla2.0b7

Status

defect
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: t.matsuu, Assigned: t.matsuu)

Tracking

unspecified
mozilla2.0b7
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

After fixing bug 594322, --enable-system-cairo still broken.

According to cairo configure script, skia backend is disabled by default:
  --enable-skia=[no/auto/yes]
                          Enable cairo's Skia surface backend feature
                          [default=no]

So I'm afraid that skia is disabled on most Linux distributions.
CAIRO_SURFACE_TYPE_SKIA is defined unconditionally in cairo/cairo.h, but doesn't exist in cairo-1.8.8 (which is minimal needed version).

So maybe it's appropriate to bump minimal required cairo version to use --enable-system-cairo instead of ifdef (in-tree cairo is already updated to 1.10).
CAIRO_SURFACE_TYPE_SKIA requires cairo-1.10.
Attachment #474657 - Attachment is obsolete: true
Attachment #474679 - Flags: review?(jdaggett)
Attachment #474679 - Flags: review?(jdaggett) → review?(jmuizelaar)
Keywords: checkin-needed
Assignee: nobody → t.matsuu
Component: Graphics → Build Config
OS: Linux → All
QA Contact: thebes → build-config
Hardware: x86_64 → All
Summary: CAIRO_SURFACE_TYPE_SKIA should be ifdefed → Update required cairo version to 1.10
Patch needs approval2.0.
Keywords: checkin-needed
Attachment #474679 - Flags: approval2.0?
Depends on: 597945
No longer depends on: 597945
Comment on attachment 474679 [details] [diff] [review]
Updte required cairo version to 1.10

I think cairo in m-c really requires 1.10. So this patch should be applied and low risk.
Keywords: checkin-needed
Status: NEW → ASSIGNED
Duplicate of this bug: 600576
:vlad

Can I get approval2.0+ for attachment 474679 [details] [diff] [review]?
Requesting blocking, as we need this for Linux distros to actually upgrade their cairo versions.
blocking2.0: --- → ?
blocking2.0: ? → final+
Comment on attachment 474679 [details] [diff] [review]
Updte required cairo version to 1.10

Sure
Attachment #474679 - Flags: approval2.0? → approval2.0+
Will this new cario version fix the major performance regression the previous one caused? See bug 595671 comment 13.
(In reply to comment #9)
> Will this new cario version fix the major performance regression the previous
> one caused? See bug 595671 comment 13.

hg:f236632a9747 referred in bug 595671 comment #13 has been pushed at 2010-04-26 which is before internal cairo is updated to 1.10. And I cannot find the word "cairo" in comments of Bug 595671.

So I think bug 595671 is not concerned with this bug.
(In reply to comment #10)
> And I cannot find the word "cairo" in comments of Bug 595671.
> 
> So I think bug 595671 is not concerned with this bug.

The work "cairo" is in bug 542605, which caused the regression, as stated in bug 595671 comment #13.
I meant "word," not "work," of course.
This bug only fixes required cairo version string in configure script. Cairo in m-c has been already updated to 1.10 which have new function. So the configure script in m-c should require cairo-1.10.

I don't know bug 595671 is fixed by cairo-1.10. If the bug is not reproduced by the latest "official" nightly binary, the bug may be caused by old cairo. If you still see the bug 595671, the bug is out of cairo-1.10 or still not fixed in cairo-1.10.

Please note that this bug never change gfx/cairo files. This means this bug is never affected to bug 595671.


Thanks.
http://hg.mozilla.org/mozilla-central/rev/603a3fbf5c50
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Blocks: 608484
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Raising the minimum version of cairo to 1.10.0 means also to update Glib-2.0 to at least 2.14 which isn't installed/shipped on CentOS5/RHEL5/ScientificLinux5.
When I tried to build cairo I got undefined symbols.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.