lots of cookie related IO when loading pages

RESOLVED DUPLICATE of bug 595925

Status

()

RESOLVED DUPLICATE of bug 595925
8 years ago
8 years ago

People

(Reporter: tnikkel, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Create a new profile (not needed, but just to show that it happens in a clean profile). Goto http://www.forbes.com/2007/01/17/richest-women-entertainment-tech-media-cz_lg_richwomen07_0118womenstars_lander.html click "In Pictures: The 20 Richest Women In Entertainment". Click next through about 10 pictures. Close the browser and restart. Visit the same url and perform the same steps. I get constant harddisk churn. It ends if I pause long enough between clicking links.

I bisected this to http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c402a67ba0db&tochange=6d0d4c0c8890 so bug 572223.

If I disable cookies in the options then the problem goes away.

I tried vacuuming the cookies.sqlite file, it didn't help.
blocking2.0: --- → ?

Comment 1

8 years ago
Try the fix for bug 595925 (or wait for post-b7).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595925

Comment 2

8 years ago
Dupee has final+.
blocking2.0: ? → ---
(In reply to comment #1)
> Try the fix for bug 595925 (or wait for post-b7).
I'll note that we are still doing the I/O, it's just that it's no longer on the main thread.
(Reporter)

Comment 4

8 years ago
Bug 595925 seems to reduce the noise coming from my harddrive to what is was before bug 572223.
You need to log in before you can comment on or make changes to this bug.