Closed Bug 600846 Opened 10 years ago Closed 10 years ago

Multitouch: Starting zoom with bottom finger on Find in Page search field brings up Desktop Firefox input field context menu

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: aakashd, Assigned: wesj)

Details

Attachments

(2 files, 1 obsolete file)

Attached image bug screenshot
Build Id:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b1pre

Steps to Reproduce:
1. Go to www.mozilla.org
2. Click on the favicon to open the site panel
3. Click on Find in Page
4. Begin a multitouch with the bottom finger starting on the Find in Page search field
5. Move the fingers in until you see the Desktop Firefox input field context menu

Actual Results:
The context menu will appear where you released the bottom finger off the screen.

Expected Results:
The Desktop Firefox context menu should never pop-up
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b2+
sounds like this related to bug 599066
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attached patch patch (obsolete) — Splinter Review
This is triggering a "click and hold" context menu.  Disabling ui.click_hold_context_menus fixes the bug, and we don't need that pref for content anymore.

We might want to re-enable this if we add context menus to chrome text fields in the future, e.g. for bug 585875.  If so then we might need a different fix for this bug.
Attachment #479859 - Flags: review?(mark.finkle)
I'm glad we have a workaround, but I'm more interested to know why the problem happens at all. Why is a long tap happening?
This isn't really a long-tap event in the Fennec sense. Its from:

http://mxr.mozilla.org/mozilla-central/source/content/events/src/nsEventStateManager.cpp#1754

which I think then fires the context menu from:

http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/textbox.xml#505
Yeah, nsEventStateManager uses "ui.click_hold_context_menus" to fire the long-tap.

Wes, can you do a quick test to check what happens if we turn off "ui.click_hold_context_menus" and add a context menu to something in chrome? Does the Fennec "LongTap" kick in and fire something we can use to show a context menu?
We can still pick up our own "TapLong" events, with or without the pref. Just have to add a listener. We can use those in chrome, and even use the context attribute if we want, to show the correct context menu. Is that what you're asking?

It seems silly to me that every XUL text field holds its own context menu.
(In reply to comment #6)
> We can still pick up our own "TapLong" events, with or without the pref. Just
> have to add a listener. We can use those in chrome, and even use the context
> attribute if we want, to show the correct context menu. Is that what you're
> asking?

Yes, that is exactly what I wanted to know. If that is the case, I'll r+ the patch.
Attachment #479859 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/9cb5e452f73c
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b7pre) Gecko/20101008 Namoroka/4.0b7pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?(mozaakash)
Backed out because of bug 602868:
http://hg.mozilla.org/mobile-browser/rev/d603ff51886a
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Sorry to steal from you Matt. This just kills these two bindings. textbox-input-box only has things dealing with the context menu as far as I can see. The spell check one only has things dealing with the context menu and spell check, which we don't use. So I just killed them both.

Alternatively, we could put in the effort to make menupopups work.
Attachment #479859 - Attachment is obsolete: true
Attachment #482370 - Flags: review?(mark.finkle)
Comment on attachment 482370 [details] [diff] [review]
Remove context menu

creative approach
Attachment #482370 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/28bc43358a35
Assignee: mbrubeck → wjohnston
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
litmus testcase https://litmus.mozilla.org/show_test.cgi?id=13672 created to regression test this bug.
Flags: in-litmus?(mozaakash) → in-litmus+
Mozilla/5.0 (android Linux armv7l; rv:2.0b7pre) Gecko/20101029 Firefox/4.0b8pre Fennec/4.0b2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.