Closed Bug 600965 Opened 10 years ago Closed 9 years ago

Mac nightly build very very buggy when run on PPC

Categories

(SeaMonkey :: Build Config, defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: quicksilver8, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100929 Firefox/ SeaMonkey/2.1b1pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100929 Firefox/ SeaMonkey/2.1b1pre

Nightly 30 september build for my PPC Quicksilver very buggy. It opens windows (browser, mail, etc.) completely blank. Gone back to 26 september build

Reproducible: Always
Summary: Today nighlty build very very buggy → Mac nightly build very very buggy when run on PPC
Perhaps related to: Bug 600832?
(In reply to comment #1)
> Perhaps related to: Bug 600832?

Downloaded today latest build (3 october). Still buggy on my PPC: show all pages blank (browser, mail, etc.). On my Intel, instead, it's OK.

What about mactests download? For what is it? And where must I relocate this folder?
Hardware: x86 → PowerPC
Version: unspecified → Trunk
Downloaded nightly build today october 4. Still fails to open. All windows blank. Last good version again from 26 september.
(In reply to comment #1)
> Perhaps related to: Bug 600832?

I don't think so, this is PPC bustage while Intel works, and we only run "make package" once, AFAIK.

This is probably due to some change that goes unnoticed now that PPC isn't supported well any more by the platform. We knew that we'll need to de-support PPC for 2.1 final, maybe we somehow need to do that for Beta 1 already.
Setting possible dependency
Depends on: 587799
Downloaded 5 october nightly build... nothing. Same situation, doesn't work with PPC. With Intel, OK.
Downloaded 5 october nightly build... nothing. Same situation, doesn't work with PPC. With Intel, OK.
Rocco, no need to post daily that it's still broken, we know that.

And as I said, the ultimate solution will be not to support PPC at all any more, and we would already have dropped it if we would have a good way out of it in terms of infrastructure.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Well. We can close this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Rocco, please note bug 621175.
There's still a little hope left...
Worst comes to the worst we could ask Cameron to compile SeaMonkey PPC builds for our contributed builds page.
Depends on: 621175
You need to log in before you can comment on or make changes to this bug.