Closed Bug 601113 Opened 9 years ago Closed 9 years ago

Port |Bug 543800 - package chrome style tests into .jar file for local testing| to comm-central

Categories

(MailNews Core :: Build Config, defect, blocker)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.3a1

People

(Reporter: sgautherie, Assigned: sgautherie)

References

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

SeaMonkey hnightlies are failing with
{
make -C mozilla package-tests
make[1]: Entering directory `/e/builds/slave/comm-central-trunk-win32-nightly/build/objdir/mozilla'
make[1]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-nightly/build/objdir/mozilla'
make[1]: *** No rule to make target `package-tests'.  Stop.
}
Callek did a bugfix for that in http://hg.mozilla.org/comm-central/rev/3b49ae48e232, but I don't know why this didn't work for our nightly builders. I can't reproduce this locally.
(In reply to comment #1)
> http://hg.mozilla.org/comm-central/rev/3b49ae48e232

"[Attempt to] Fix OSX bustage from m-c Bug 543800"

Indeed, it seems to have already fixed usual tinderbox builds :-)
But that was only a part of the needed port...
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Flags: in-testsuite-
Untested, but that should be it. (for the common part at least)
Attachment #480098 - Flags: review?(bugspam.Callek)
Attached patch (Cv1-TB) Update build.mk (obsolete) — Splinter Review
Untested, but that should be it.
Attachment #480102 - Flags: review?(bugzilla)
Cv1-TB, with testsuite-targets.mk part included.
Attachment #480102 - Attachment is obsolete: true
Attachment #480104 - Flags: review?(bugzilla)
Attachment #480102 - Flags: review?(bugzilla)
Duplicate of this bug: 601069
Blocks: SmTestFail
(In reply to comment #3)
> Created attachment 480098 [details] [diff] [review]
> (Bv1) (Missed) Makefile.in part

I don't think our problem here isn't above all the Makefile.in, but that we call make package-tests if tests are disabled. With the patch, the call just fails earlier, because we don't have the target in our Makefile anymore.

So either we can configure buildbot that the target isn't called at all for disabled tests or we have to patch our Makefile.in to be something like that:

ifndef MOZ_THUNDERBIRD
package-tests:: $(SUBMAKEFILES)
ifdef ENABLE_TESTS
  $(MAKE) -C mozilla $@
endif
endif

This would retain the target but only do something, if tests are enabled.
Depends on: 545172
(In reply to comment #7)

> we call make package-tests if tests are disabled.

Yeah, that's a different issue:

> So either we can configure buildbot that the target isn't called at all for

That's what I would (have) expect actually!
Yet, bug 545172 should enable tests now :-)
Then we shouldn't care anymore. But you can file a bug about that if you want.

> disabled tests or we have to patch our Makefile.in to be something like that:

I fully agree with this workaround, but only if bug 545172 is refused for some reason.
(In reply to comment #9)

> Yet, bug 545172 should enable tests now :-)
> Then we shouldn't care anymore. But you can file a bug about that if you want.
If we get tests enabled again, that would be the best solution, of course :-)
Attachment #480187 - Attachment description: (Dv1-SM) Fix mochitest-browser-chrome tests: s|chrome://mochikit/content|http://mochi.test:8888| → (Dv1-SM) Fix mochitest-browser-chrome tests: s|chrome://mochikit/content|http://mochi.test:8888| [Superseded by bug 601069]
Attachment #480187 - Attachment is obsolete: true
Attachment #480187 - Flags: review?(bugspam.Callek)
Depends on: 601069
No longer blocks: SmTestFail
Attachment #480104 - Flags: review?(bugzilla) → review+
Comment on attachment 480104 [details] [diff] [review]
(Cv1a-TB) Just port it
[Checked in: Comment 11]

http://hg.mozilla.org/comm-central/rev/7a7aa0052f04
Attachment #480104 - Attachment description: (Cv1a-TB) Just port it → (Cv1a-TB) Just port it [Checked in: Comment 11]
Depends on: 601471
Comment on attachment 480098 [details] [diff] [review]
(Bv1) (Missed) Makefile.in part
[Checked in: Comment 13]

sure. [I'll get Bug 601069 review in a day or two, real life is crowding my time]
Attachment #480098 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 480098 [details] [diff] [review]
(Bv1) (Missed) Makefile.in part
[Checked in: Comment 13]

http://hg.mozilla.org/comm-central/rev/b776fde61d23
Attachment #480098 - Attachment description: (Bv1) (Missed) Makefile.in part → (Bv1) (Missed) Makefile.in part [Checked in: Comment 13]
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
You need to log in before you can comment on or make changes to this bug.