Closed Bug 601207 Opened 9 years ago Closed 9 years ago

mxr.mozilla.org/comm-central not being updated properly

Categories

(MailNews Core :: Build Config, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Callek, Assigned: Callek)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Very recently the mozilla/* subdir of comm-central MXR repo is no longer updating, I suspect the client.py script is not being run.

Possibly related to: http://hg.mozilla.org/comm-central/rev/25e697e42d9a [Bug 599743]

Is it erroring out, or is it simply a server mistake?

I noticed from: http://mxr.mozilla.org/comm-central/search?string=package-tests vs http://mxr.mozilla.org/mozilla-central/search?string=package-tests

If it is due to error's, consider rs+=me for backout of the client.py change if it is far easier than upgrading python on mxr's host(s)
Assignee: server-ops → jdow
(In reply to comment #0)

> Very recently the mozilla/* subdir of comm-central MXR repo is no longer
> updating

Indeed, I noticed it today.

> If it is due to error's, consider rs+=me for backout of the client.py change if
> it is far easier than upgrading python on mxr's host(s)

Agreed, in the short term;
though I would support the python upgrade, in the long run.
We can upgrade Python if you'd like, but there's considerations involved in the client code calling it.  We can't replace the system python because most of RHEL's OS utilities are written in python, and all of the libraries are specific to the version of python provided by RHEL (2.4.3 currently).  So we have to install python 2.6.2 in an alternate location, and it will need to be called specifically as /usr/bin/python26 (/usr/bin/python will continue to point at python 2.4.3).  If there's not any shelling out to other python files via bash, and we only have to change the way mxr is calling it initially, that should be an easy fix if you'd like to go that route.
(In reply to comment #2)

http://mxr.mozilla.org/comm-central/source/client.py

client.py calls hg and cvs only.
Running client.py from any python v2.5+ (= v2.6.2 i.e.) should be just fine.
(= worth a try at least.)
Assignee: jdow → justdave
As client.py owner, I don't want to add the burden on mozilla for this at this time, I'm going to backout when I get home. Moving bug and assigning to myself
Assignee: justdave → bugspam.Callek
Component: Server Operations → Build Config
Product: mozilla.org → MailNews Core
QA Contact: mrz → build-config
Version: other → Trunk
(In reply to comment #4)
> I'm going to backout when I get home.

Hum. Then maybe just add a comment about this...
Blocks: 599743, 599748
Status: NEW → ASSIGNED
Flags: in-testsuite-
(In reply to comment #5)
> Hum. Then maybe just add a comment about this...

Ah, and keep ">=".
backed out with http://hg.mozilla.org/comm-central/rev/55311f5d4576
and added a comment and grammar nit as per serge in http://hg.mozilla.org/comm-central/rev/51fbb624b47a
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Sadly, mxr was updating by client.py only, so took longer to update; After catching justdave on IRC he manually kicked it, and I just verified that it is indeed updated for us.
Status: RESOLVED → VERIFIED
No longer blocks: 599748
MXR is being moved to a new RHEL6 environment this week, which is Python 2.6 instead of 2.4. This means Python 2.4 is no longer a requirement, as far as MXR is concerned. I don't know if anything else still requires it (I think not, but maybe).
You need to log in before you can comment on or make changes to this bug.