With layers.accelerate-all enabled on 10.6.4 x86_64 nightly - chrome drawing/rendering issues

RESOLVED DUPLICATE of bug 603134

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 603134
9 years ago
9 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({regression})

Trunk
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20101002 Firefox/4.0b7pre

This started happening on September 29th with Mac 10.6.4 x86_64 nightly builds

STR: Start the browser
1. See issues trying to load about:home
2. Try opening a tab

layers.accelerate-all = true

The issue disappears when layers.accelerate-all is flipped to false.
Reporter

Updated

9 years ago
Summary: With layers enabled on 10.6.4 x86_64 nightly - chrome drawing/rendering issues → With layers.accelerate-all enabled on 10.6.4 x86_64 nightly - chrome drawing/rendering issues
Reporter

Updated

9 years ago
blocking2.0: --- → ?
Reporter

Updated

9 years ago
Blocks: ogl-osx-beta
Reporter

Comment 2

9 years ago
With this issue, I can not see new tabs opening for example.

If I minimize the browser to dock and let it redraw on focus, I see all tabs that previously would not be drawn as opening
OS: Mac OS X → Windows 7
Reporter

Updated

9 years ago
OS: Windows 7 → Mac OS X
I've seen issues like this before. Can you try the try builds that will appear at http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/jdrew@mozilla.com-236df825e879 ? (It'll probably be a couple of hours before they appear.)
Reporter

Comment 4

9 years ago
Was going to actually mention this afternoon that the behaviour vanished with my Oct 3rd build and now updated to Oct 4th. Will check out those builds too.
Can you go into System Profiler and tell me what sort of graphics card you have in your Mac?
Removing blocking nomination until we can reproduce.
blocking2.0: ? → ---
Reporter

Comment 7

9 years ago
Chipset Model: NVIDIA GeForce 9400M
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Reporter

Comment 8

9 years ago
(In reply to comment #3)
> I've seen issues like this before. Can you try the try builds that will appear
> at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/jdrew@mozilla.com-236df825e879
> ? (It'll probably be a couple of hours before they appear.)

No issue with this build
Reporter

Comment 9

9 years ago
This issue was gone for for the past week and a half and returned in the 10/20 nightly and 21st
OS: Mac OS X → Windows 7
Reporter

Updated

9 years ago
OS: Windows 7 → Mac OS X
Reporter

Updated

9 years ago
blocking2.0: --- → ?
Reporter

Comment 10

9 years ago
Because it's somewhat difficult to describe, I've recorded a video.

http://www.youtube.com/watch?v=Fh-FNClok_s

I open minefield, about:home does not display. The tab indicates "Connecting...". I hit cmd-t to open a bunch of tabs but they don't draw yet. I quickly open the Add-ons Manager and it doesn't appear. I shortcut to PB, and I see the AMO behind the modal dialog, and nothing gets repainted.
If you move the window, things draw correctly, right? And if you reboot, it works for a while?
Reporter

Comment 12

9 years ago
(In reply to comment #11)
> If you move the window, things draw correctly, right? And if you reboot, it
> works for a while?

Move, yep. Reboot, have not rebooted in ages.
It's sort of intermittent, yeah.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603134
blocking2.0: ? → final+
You need to log in before you can comment on or make changes to this bug.