Closed Bug 580405 (ogl-osx-beta) Opened 10 years ago Closed 10 years ago

[Tracking bug] [Mac OS X] Turn on OpenGL accelerated layers by default for at least some subset of hardware

Categories

(Core :: Graphics, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: joe, Assigned: joe)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [ETA: decision for beta 7 to be made on 10/1])

Attachments

(1 file)

This is a tracking bug for all things needed before we turn on OpenGL accelerated layers by default for at least some subset of hardware.
Depends on: 580410
blocking2.0: --- → betaN+
Who owns this?  Need an owner ASAP.
Depends on: 582816
Depends on: 582818
Tracking bugs don't need owners, but let's give it one anyways.
Assignee: nobody → joe
Depends on: 584536
Depends on: 586462
Depends on: 586463
Depends on: 586464
Depends on: 586465
Depends on: 586796
Depends on: 586839
Depends on: 586862
Blocks: 564978
Depends on: 594308
Alias: ogl-beta
Depends on: 594862
Depends on: 594796
Alias: ogl-beta → ogl-osx-beta
Summary: [Tracking bug] Turn on OpenGL accelerated layers by default for at least some subset of hardware → [Tracking bug] Turn on OpenGL accelerated layers by default for at least some subset of hardware on OS X
Given the subject change: what about linux?
(In reply to comment #3)
> Given the subject change: what about linux?

Bug 594876
No longer depends on: 586463
No longer depends on: 586462
No longer depends on: 582816
No longer depends on: 582818
Depends on: 595055
No longer depends on: 580756
Depends on: 595156
No longer depends on: 594862
Duplicate of this bug: 594920
Depends on: 596414
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595055
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
No longer depends on: 594308
So, this is blocking BetaN+, but I'm not sure we want to turn this on after Beta 7. Joe: what say you?
This should have been beta 7 all along!
blocking2.0: betaN+ → beta7+
Attachment #477217 - Flags: review?(vladimir)
Whiteboard: [ETA: 9/23]
Depends on: 595933
Depends on: 598538
(rearranging bug title wording so the Linux and Mac tracking bugs don't look exactly the same in bugmail when truncated; don't bury the lead)
OS: All → Mac OS X
Summary: [Tracking bug] Turn on OpenGL accelerated layers by default for at least some subset of hardware on OS X → [Tracking bug] [Mac OS X] Turn on OpenGL accelerated layers by default for at least some subset of hardware
Depends on: 596493
Depends on: 599241
Whiteboard: [ETA: 9/23] → [ETA: decision for beta 7 to be made on 10/1]
Depends on: 598143
No longer depends on: 595156
Comment on attachment 477217 [details] [diff] [review]
accelerate layers by default on os x

oh god what have I done
Attachment #477217 - Flags: review?(vladimir)
Attachment #477217 - Flags: review+
Attachment #477217 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/212684e5990a
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20101001 Firefox/4.0b7pre

Is logging enabled on purpose?

Seeing console output such as:

[...]
Found extension GL_ARB_framebuffer_object
Found extension GL_EXT_framebuffer_object
Found extension GL_ARB_texture_rectangle
Found extension GL_EXT_bgra
Depends on: 601403
Depends on: 611292
You need to log in before you can comment on or make changes to this bug.