no Referer: header for iframe content

VERIFIED DUPLICATE of bug 57076

Status

()

P3
major
VERIFIED DUPLICATE of bug 57076
18 years ago
3 months ago

People

(Reporter: estartu, Assigned: pollmann)

Tracking

({testcase})

Trunk
mozilla0.9.1
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; FreeBSD 4.2-BETA i386; Nav)
BuildID:    2000101015

mozilla doesent send an Referer: Header when requesting content of 
an iframe. 

Reproducible: Always
Steps to Reproduce:
1. open the page	
2.
3.

Actual Results:  null.gif is show because our banner engine checks for the
referer 
haeder to verify the site is allowed to use our banner

Expected Results:  Ad banner shown in iframe

Comment 1

18 years ago
Gerhard Schmidt, I see a banner appearing on your URL. So I guess it's working.
I'm using the 2000111704 build on Windows 98.
(Reporter)

Comment 2

18 years ago
Thats because we have deaktivated referrer check for user-agent matching
*gecko* because some of our customers complained about Netscape 6 not
working also.

But this is only a Temporary Fix.

Comment 3

18 years ago
This works fine for me.
Platform: PC
OS: Windows 98
Mozilla Build: #2000121804 M18 Trunk Build

Marking WORKSFORME reopen if its still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
It work because have build a Temporary workaround in our Banner engine but that
don´t change the bug. I have already wrote this in an comment on this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

18 years ago
Well can you setup a test case we can work on? Otherwise we cant fix the problem.
I've set up a testcase for this at
http://www.zbarsky.org/~bzbarsky/moztest/referer.html

Indeed, Mozilla does not pass a Referer: header to the frames in a frameset
(linux build 2000-12-05-08).  NS 4.x does.

Comment 7

18 years ago
Marking NEW and adding keyword testcase.
Keywords: testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Marking new for real
Setting milestone to mozilla0.9.1.
Eric is this a common issue?
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 10

18 years ago
Seems it is a pretty common problem....  :)

*** This bug has been marked as a duplicate of 57076 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
QA Contact update
QA Contact: petersen → amar

Comment 12

18 years ago
verified
Status: RESOLVED → VERIFIED

Updated

3 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.