HTTP referrer not sent for iframe request

VERIFIED WORKSFORME

Status

()

Core
Layout: HTML Frames
P1
major
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Eugene Savitsky, Assigned: Eric Pollmann)

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
look at this page. There should be 3 banner, but in Moz we see only 
scrollbars...

This going on with all http://www.linkexchange.ru:8080 banners.

With this are affected most of .ru sites.

Comment 1

17 years ago
over to HTML Element
Assignee: asa → clayton
Component: Browser-General → HTML Element
QA Contact: doronr → lorca

Comment 2

17 years ago
attaching relevant portion of page. some iframe stuff inside a table.  we show
scrollbars and 4.x and ie do not.

Comment 3

17 years ago
Created attachment 17695 [details]
snip of webpage in case their content changes
(Reporter)

Comment 4

17 years ago
Must I post here a list of sites this is affected on?

2/3 .ru sites (and 90% of most popular .ru sites) have this issue... Please do 
smth with this for RTM! 

To get attention I raise the priority and severity.
Severity: normal → critical
Priority: P3 → P1
(Reporter)

Updated

17 years ago
Keywords: rtm
todays branch build is capable of displaying the images in attachment 17695 [details] if
you first go into 4.x and use view image to get the URL and paste the URL into
Mozilla. So the problem is not the RLE images. The problem must either be the
iframes used to layout the image or converting the absolute URL used to load the
image. Reassigning to pollmann to investigate further.
Assignee: clayton → pollmann
(Assignee)

Comment 6

17 years ago
This looks like a server-side problem with linkexchange.ru to me.

Nav does not display the iframes (<iframe> is not implemented in Nav, so it
displays the alternate content inside the <iframe> tag), but in IE, they look
fine.  Here's an example URL:

http://www.linkexchange.ru/cgi-bin/erle.cgi?23385?2179

when I load this URL with Moz (or even directly telnetting to the server and
requesting it, I get an HTTP redirect to:

http://rle-mirror.agtel.net/users/expelled.gif

That is a blank GIF image, which is correctly displayed in Nav as a blank
rectangle.  When I fetch this with IE, a page is loaded.  My guess is that the
site is doing User-Agent sniffing and showing us the page it gives to "unknown"
user agents.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

17 years ago
Marking this evangwanted.  I don't think I'll have time to do a full
investigation for RTM, but am pretty sure that this can be corrected very simply
on the server side.
Keywords: evangwanted
Marking rtm-, based on Eric's comments that this is a server-side browser
sniffing issue.
Whiteboard: [rtm-]

Comment 9

17 years ago
It's pretty easy, really...
It turned-out that NN6 does not submit an http referrer for iframe request. 
With no referrer at all, the algorithm that filters illegal activities in our 
banner network comes into play - and redirection to expelled.gif occures 
instead of standard text/html output.
S. Bogdanov, RLE dev.team
(Assignee)

Comment 10

17 years ago
Thanks stas@homepage.ru, I'll look into why we aren't sending the referrer along
with requests for iframes.  :)
Severity: critical → major
Component: HTML Element → Networking: HTTP
OS: Windows 98 → All
Hardware: PC → All
Summary: RLE banners do not displayed in Mozilla → HTTP referrer not sent for iframe request

Updated

17 years ago
Keywords: evangwanted
(Reporter)

Comment 11

17 years ago
Now all looks fine.
Was this fixed in mozilla or on linkexchange.ru?
(Reporter)

Comment 12

17 years ago
It is defenetly not fixed in mozilla since NS6 also shows all banners.
Linkexchange did smth on they engine.

Updated

17 years ago
QA Contact: lorca → tever

Comment 13

17 years ago
Tossing over to tever, who should own this one....
Reassigning bug to bclary@netscape.com
Changed component to Evangelism.
Assignee: pollmann → bclary
Status: ASSIGNED → NEW
Component: Networking: HTTP → Evangelism
(Assignee)

Comment 15

17 years ago
Grabbing back - I still haven't taken care of this.  Sorry for the spam!
Assignee: bclary → pollmann
Component: Evangelism → HTMLFrames
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 16

17 years ago
*** Bug 60141 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

17 years ago
Created attachment 30018 [details]
test case
(Assignee)

Comment 18

17 years ago
Working now.  To verify, open up the test case.  You should see:

A page with a black box.  Inside the black box, it should say:

"http://bugzilla.mozilla.org/showattachment.cgi?attach_id=30018 sent you to me."

In Netscape 6, which had this bug, the black box will say: "I dunno."
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Blocks: 75664

Comment 19

17 years ago
checked with test case, marking verified WinNT4 2001052204
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.