Last Comment Bug 602150 - After doorhangers land cant type in textbox
: After doorhangers land cant type in textbox
Status: VERIFIED FIXED
[Fixed by bug 595810][doorhanger]
: regression
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: All All
: -- major (vote)
: seamonkey2.1b1
Assigned To: neil@parkwaycc.co.uk
:
:
Mentors:
: 602249 (view as bug list)
Depends on:
Blocks: 595810
  Show dependency treegraph
 
Reported: 2010-10-05 23:27 PDT by Misak Khachatryan
Modified: 2011-02-12 13:26 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Misak Khachatryan 2010-10-05 23:27:16 PDT
I can't type in almost any textbox, because it didn't get focus by clicking on them. If i right-click on it or select it via tab key, textbox gets focused and i was able to type on it. It also get focused if i middle-click on it to paste something. It was ok http://hg.mozilla.org/comm-central/rev/086d167a0505 with this cset and not ok after this one - http://hg.mozilla.org/comm-central/rev/c55ed62b37cd .
Comment 1 Justin Wood (:Callek) 2010-10-06 00:04:28 PDT
This bug report seems to be missing one key answer that I asked in IRC and thought I recieved the answer clearly, but perhaps I was wrong.

Does it exhibit this issue AFTER http://hg.mozilla.org/comm-central/rev/8e1c8d540686 landed ?
Comment 2 Misak Khachatryan 2010-10-06 00:26:59 PDT
Yes, SM is still have this bug with cset above. Also disabling doorhangers via pref have no effect too.
Comment 3 neil@parkwaycc.co.uk 2010-10-06 01:48:41 PDT
The bug was caused by my misuse of the reserved attribute name "popup".

I've renamed the attribute which makes the tests pass locally again.
Comment 4 Misak Khachatryan 2010-10-06 04:22:45 PDT
This bug was fixed by http://hg.mozilla.org/comm-central/rev/2342338033d4
Comment 5 Misak Khachatryan 2010-10-06 04:22:58 PDT
This bug was fixed by http://hg.mozilla.org/comm-central/rev/2342338033d4
Comment 6 Misak Khachatryan 2010-10-06 22:40:43 PDT
*** Bug 602249 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.