Closed Bug 602173 Opened 12 years ago Closed 11 years ago

Firefox Sync 1.5 locales are missing files

Categories

(Firefox :: Sync, defect)

defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: toniher, Unassigned)

References

Details

Attachments

(1 file)

Attached file Sync error log
Hello,

I cannot sync content using Firefox 3.6.10 and Firefox Sync 1.5. I assume that during a test with Firefox 4 beta, or Sync betas I might have messed up data. However, I erased them all and tried to start again. 

I attach a sync log.
Comment on attachment 481188 [details]
Sync error log

>2010-10-06 13:34:44	Service.Main         DEBUG	Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIStringBundle.GetStringFromName] Stack trace: anonymous()@StringBundle.js:132 < _ensureMobileQuery()@bookmarks.js:1154 ...

It's failing on this line:

    let title = Str.sync.get("mobile.label");

This is a string that should be in sync.properties. I looked at the 1.5 XPI and it seems it's missing the whole sync.properties file altogether in a bunch of locales, including the Spanish ones.
The reason why these locales are missing files is because the en-US export is missing them too :(

When we changed the directory structure of the fx-sync repository, the hg convert filemap probably wasn't updated, so these files just disappeared: http://hg.mozilla.org/weave-l10n/en-US/rev/4bbc3b1a2264
Component: Firefox Sync: Backend → Firefox Sync: Build
OS: Linux → All
QA Contact: sync-backend → sync-build
Hardware: x86 → All
Summary: Error syncing with Firefox Sync 1.5 → Firefox Sync 1.5 locales are missing files
I have removed 1.5 from AMO until we respin the build that won't break on the locales in question.
(In reply to comment #3)
> I have removed 1.5 from AMO until we respin the build that won't break on the
> locales in question.

Thanks Philipp, let us know if we can help in anything.
Ohoh. Of course all locales that updated removed the services files, of course.

Oth, can you get to the services files from fx 4?
(In reply to comment #5)
> Oth, can you get to the services files from fx 4?

Yup, we could, and they should be identical. But tbh I'd be more comfortable with the localizers doing that and getting them to sign off on that. Until they do that we probably want to ship 1.5 without the broken locales.
That'd be "none" at this point in time, though. :-(
The ar, de, fi, id, ja, nl, pl, pt-BR, vi locales do have those files, though! I don't know if that's just pure chance or their localizers actually tested sync (which I thought was part of the sign-off process tbh)...
If you're looking at https://l10n-stage-sj.mozilla.org/shipping/dashboard?av=weave, that's mostly overlapping with those locales that didn't do anything since 1.3.
You're right. We're doing 1.5 as en-US only for now. Just uploaded it to AMO.
So we just need to add the /services/ directory, right? both files: sync.properties and error.properties. And are these files the same from the Firefox /services/ module?

(in the es-ES case, I hg removed both files in a single changeset, should be easy to backout that and merge with tip)
(done for es-ES, waiting for a new push to en-US to see if all is correct: http://hg.mozilla.org/weave-l10n/es-ES/graph )
There's a new push to en-US.  You're down to 18 new strings in those two files, according to l10n dashboard.
(In reply to comment #8)
> The ar, de, fi, id, ja, nl, pl, pt-BR, vi locales do have those files, though!
> I don't know if that's just pure chance or their localizers actually tested
> sync (which I thought was part of the sign-off process tbh)...

Honestly I didn't sign-off my locale (it), because I was somehow waiting for a follow-up to the initial Mike's mail in dev.l10n about version 1.5

Anyway "it" should be green in a minute.
http://hg.mozilla.org/weave-l10n/it/rev/e63ffb6e68c4
When Firefox Sync 1.5.1 will be out? Philipp's post to the dev-l10n list said "Firefox Sync 1.5.1, cutting beta today/tomorrow" as of last week, but I haven't seen Beta 2 at
http://ftp.mozilla.org/pub/mozilla.org/labs/weave/development/1.5.x/

Some users are confused about the English UI of 1.5 :( 
We'd like to see the localized version asap.
I've been fighting with build issues, and some other unrelated stuff.  I think I have working build-fu now, will spin a test build ASAP to see.
Duplicate of this bug: 607256
Fixed by 1.5.1 betas
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
verified 1.5.1 beta on Italian
Status: RESOLVED → VERIFIED
Firefox Sync is no longer beta stage. Half the users have non en-US locales. Please never release English-only versions again.
The functionality of 1.5 was necessary to support the Fennec Beta release, so we couldn't simply pull the release until problems were solved.  None of the options were good, but we had little choice here.

I do understand and share the concern, but please do understand that things are not always that simple.
Component: Firefox Sync: Build → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.