Closed Bug 602205 Opened 9 years ago Closed 9 years ago

List all tabs doesn't limit ctrl-Tab results to the current tab list of the currently active panorama group

Categories

(Firefox Graveyard :: Panorama, defect, minor)

x86
All
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 604381

People

(Reporter: rakshithbekal, Unassigned)

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

I have enabled the tab switch option using the ctrl-tab as aero which shows "list all tabs " button on my tab strip . This feature fails to recognize the current opened panorama group and lists all the loaded pages (from all panorama groups of tabs )  in a shuffled mode when pressing "ctrl-tab"

Reproducible: Always

Steps to Reproduce:
1.Enable "browser.allTabs.previews" in about:config
2.open a bunch of tabs and group them in panorama
3. open a random page from a random group and keep note of all pages in that group
4.click ctrl-tab ,you see an aero option for tab switching which shows mixed pages from all group.
Actual Results:  
cannot keep track of the pages in the panorama group

Expected Results:  
this is mostly not a bug but please implement the new feature in firefox 4 beta 7 as pages from the specific panorama group will not all be present while viewing using ctrl-tab switching. 

By the way the "list all tabs" button on my tab strip works fine though (shows all the pages from the current panorama group  open in a grid view in aero below the tab strip)
actually it returns with recently opened tabs from other panorama group
-> tab candy.
Component: General → TabCandy
QA Contact: general → tabcandy
Summary: List all tabs in glass (aero) option in firefox 4 should limit ctrl-Tab results to the current tab list of the specific panorama group we have opened. → List all tabs doesn't limit ctrl-Tab results to the current tab list of the currently active panorama group
My ctrl+tab seems to be working fine with allTabs.previews set to true. I hit ctrl+tab (without hitting the list all tabs" button) and I move between the tabs in my group.

Do you have another pref turned on? Can you upload a screenshot?
take note of the preview picture or the name of website
Does Firefox build release save all my firefox configurations because I Never wanted to install any build because I Thought It would erase my preference from "about:config" since I have worked hard to configure it. In Beta 6 which I am currently using.
(In reply to comment #8)
> Does Firefox build release save all my firefox configurations

Yes.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
It Doesn't Show Any  tabs And Getting Out Of Tab Candy Using ctrl+e Didnt Work So I had To Use the ribbon and open a new tab to exit tab candy
(In reply to comment #10)
> Created attachment 487418 [details]
> This Is How Tab Candy Looks Like For Me In the Latest Build
> 
> It Doesn't Show Any  tabs And Getting Out Of Tab Candy Using ctrl+e Didnt Work
> So I had To Use the ribbon and open a new tab to exit tab candy

Looks like you are using an old version because there are multiple pencil images in the title box. Are you able to install the latest build suggested in comment 7?
OS: Windows 7 → Windows XP
The Build What I'm Using Right Now Is Newer Than The Build You Suggested. I'm Using The Latest Build. Btw Theres Other problems associated with the tab candy  Like I could Draw Empty rectangles In the Box and I cant exit From The Main close Button When I Open Tab Candy Unless I Open New Tabs And Then Quit from tabs
(In reply to comment #12)
> The Build What I'm Using Right Now Is Newer Than The Build You Suggested. I'm
> Using The Latest Build. Btw Theres Other problems associated with the tab candy
>  Like I could Draw Empty rectangles In the Box and I cant exit From The Main
> close Button When I Open Tab Candy Unless I Open New Tabs And Then Quit from
> tabs

Ah! That looks like bug you are running afoul of the JIT, bug 604381. Also the issue where you can't exit Firefox in Panorama is by design, bug 587043 has the discussion.
OS: Windows XP → All
Okay, I think You are right since I Enabled The Jit. So Whats the Use In Enabling That Jit?
(In reply to comment #14)
> Okay, I think You are right since I Enabled The Jit. So Whats the Use In
> Enabling That Jit?

The JIT has bugs when javascript is used in chrome space. Since Panorama is entirely in the chrome space, this creates a few problems until those bugs are fixed. The JIT DOES, however, speed up javascript in normal browsing.

Sorry about that!
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 604381
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.