If the wifi is turned off, it acts as if a blank account is signed in.

VERIFIED FIXED

Status

Cloud Services
Firefox Home
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: nhirata, Assigned: st3fan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 481411 [details]
Screenshot of Settings after step 5

1. sign in
2. go to settings
3. click sign out; sign out
4. go to the wifi settings, turn wifi off
5. go back into home

Expected : login prompt
Actual : no wifi connection dialog shows; you can go into the app.

Note:
1. turning on wifi will take you to the login prompt instead of signing you in

Comment 1

8 years ago
Are you saying that after you explicitly sign out, you are able to get into the app without signing in?
Assignee: nobody → stefan
This bug may be my misunderstanding of how the app works.

I explicitly signed out, turned off the wifi, and then clicked on the app.
The app doesn't have a sign on page, it goes into the app without any bookmarks, tabs, etc and the settings page will show a sign out button you can click.

Comment 3

8 years ago
I get the login prompt on iOS 4. Looks like it might be an iOS 3 only bug.

Comment 4

8 years ago
Spoke to soon, if you kill the process, you are able to reproduce it on iOS 4.
Flags: blocking-fx-home1.0.4+
Can we fix this by making Log Out be "Stop Using This Account" and wipe the local data?  FxSync is getting rid of Connect/Disconnect.

For bonus points, DELETE the client record! (see bug 565430)
(Assignee)

Comment 6

7 years ago
I can't reproduce this. I've tried on both 3.1.3 and 4.1. This is what I do:

1) Login
2) Wait for sync to complete
3) Sign Out
4) Kill the app (on iOS 4)
5) Enable airplane mode
6) Start Home

I always get the login screen.

I have only tested on a phone with Airplane Mode. I"ll try to find an iPod and see if it has the same behaviour or not.
(Assignee)

Comment 7

7 years ago
I can't reproduce this. I've tried on both 3.1.3 and 4.1. This is what I do:

1) Login
2) Wait for sync to complete
3) Sign Out
4) Kill the app (on iOS 4)
5) Enable airplane mode
6) Start Home

I always get the login screen.

I have only tested on a phone with Airplane Mode. I"ll try to find an iPod and see if it has the same behaviour or not.
(Assignee)

Comment 8

7 years ago
It is possible that this was fixed with the fix for:

https://bugzilla.mozilla.org/show_bug.cgi?id=605158

I will continue to try to reproduce this. But so far I have been unsuccessful.

Comment 9

7 years ago
I don't think this blocks 1.0.4, especially as it is proving to be hard to reproduce ( I haven't been able to do it at all on iOS 4.1).
Flags: blocking-fx-home1.0.4+
Note to self : need to retest this with the latest build.
Still occurs in latest build.

Video of the bug :
http://www.youtube.com/watch?v=Kqyvwd-w-qo
(Assignee)

Comment 12

7 years ago
Implemented a workaround that should fix this.

Changeset at http://hg.mozilla.org/services/fx-home/rev/e0976c6dca07
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified on
iPhone 3 GS : iOS 4
iPod Touch : iOS 3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.